Magento Forum

   
Installazione Bloccata nella Configurazione
 
sck
Jr. Member
 
Total Posts:  7
Joined:  2009-02-15
 

Salve a tutti smile
Sono un nuovo utente e approcciandomi per la prima volta alla realizzazione di un sito web di e-commerce per mio zio ho deciso di adottare magento. All’inizio ero orientato verso osCommerce ma poi tra una pagina e l’altra mi è saltato all’occhio questo cms che sembra davvero ben fatto.
Premetto di non avere grandissime capacità in PHP e MYSQL (vengo da ambiente ASP :’() però la volontà di imparare c’è tutta :D.
Per iniziare a giochicchiare in locale ho installato MAMP (uso un macintosh) e copiato tutti i file d’installazione nella directory del webserver.
Dopodichè avviando index.php mi si avvia l’installazione.
Il primo inghippo l’ho trovato nella schermata di configurazione....
http://img.skitch.com/20090216-jr9xsayisrfaradd2msisdihgp.preview.jpg
come da screenshot inserisco i dati e quando decido di proseguire nell’installazione mi ricarica la stessa pagina!
Sapete se devo fare altro oltre ad avviare MAMP prima di avviare l’installazione di magento? Tipo creare db o altro?
Spero di non essere lapidato per la niubbaggine :D

Saluti
sck

 
Magento Community Magento Community
Magento Community
Magento Community
 
sck
Jr. Member
 
Total Posts:  7
Joined:  2009-02-15
 

Come non detto son riuscito a capire perchè rimaneva lì in loop.
Non avevo creato il database in PHPmyAdmin. Ne ho creato uno nuovo di tipo BINARY e l’installazione si è conclusa con successo solo che quando accedo al FRONTEND mi da una pagina bianca mentre se accedo al BACKEND mi dice che il login non è corretto. Ho sbagliato qualcosa?:)

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3456
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

servizi php tutti attivi? Controlla nelle specifiche richieste da magento.
inoltre ti consiglio vivamente di utilizzare 127.0.0.1 anzichè localhost

 
Magento Community Magento Community
Magento Community
Magento Community
 
sck
Jr. Member
 
Total Posts:  7
Joined:  2009-02-15
 

Ho provato ad eseguire il magento-check.php e il risultato è questo:

Your server does not meet the following requirements in order to install Magento.
The following requirements failed, please contact your hosting provider in order to receive assistance with meeting the system requirements for Magento:

* You need MySQL 4.1.20 (or greater)

The following requirements were successfully met:

* You have PHP 5.2.0 (or greater)
* Safe Mode is off
* You have the curl extension
* You have the dom extension
* You have the gd extension
* You have the hash extension
* You have the iconv extension
* You have the mcrypt extension
* You have the pcre extension
* You have the pdo extension
* You have the pdo_mysql extension
* You have the simplexml extension

Ora sto scaricando la versione 5.31 di MySQL (mysql-5.1.31-osx10.5-x86.dmg) poi riprovo l’installazione...serve altro oltre a questi requisiti? Il database va bene di tipo binary?

 
Magento Community Magento Community
Magento Community
Magento Community
 
sck
Jr. Member
 
Total Posts:  7
Joined:  2009-02-15
 

Ho provato ad installare l’aggiornamento di MySQL senza successo :(
il check mi da sempre lo stesso errore e magento si impalla sempre a fine installazione...non mi fa accedere al backend/frontend.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3456
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

ma scusa mi risulta che l’ultima versione MySQL di MAMP sia 5.0.41.

Prova a rimuovere tutto, compreso mamp e reinstallare da capo.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sck
Jr. Member
 
Total Posts:  7
Joined:  2009-02-15
 
Black Cat - 16 February 2009 04:20 AM

ma scusa mi risulta che l’ultima versione MySQL di MAMP sia 5.0.41.

Prova a rimuovere tutto, compreso mamp e reinstallare da capo.

Appena provato ma nada :(...il check da quell’errore li mentre magento quando gli do username e password x il backend non fa niente..

 
Magento Community Magento Community
Magento Community
Magento Community
 
sck
Jr. Member
 
Total Posts:  7
Joined:  2009-02-15
 

Non so se centra qualcosa ma ho provato ad installare OsCommerce e funziona tutto. Mentre Magento non ne vuole sapere di andare :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
patrecord
Guru
 
Avatar
Total Posts:  461
Joined:  2008-06-01
 

No non ci azzecca nulla perche oscommerce ha tutti altri requisiti;) Ad ogni modo ti confermo che con MAMP funziona alla perfezione. Controlla nelle preferenze che Apache parta col supporto a php5 er non 4, che l’opzione Zend Optimize sia spuntata e la cache a “--”. Inoltre come suggerito da Black usa 127.0.0.1 invece di localhost;)

Dimenticavo...la mia è MAMP 1.7.1

 
Magento Community Magento Community
Magento Community
Magento Community
 
sck
Jr. Member
 
Total Posts:  7
Joined:  2009-02-15
 
patrecord - 16 February 2009 06:05 AM

No non ci azzecca nulla perche oscommerce ha tutti altri requisiti;) Ad ogni modo ti confermo che con MAMP funziona alla perfezione. Controlla nelle preferenze che Apache parta col supporto a php5 er non 4, che l’opzione Zend Optimize sia spuntata e la cache a “--”. Inoltre come suggerito da Black usa 127.0.0.1 invece di localhost;)


Dimenticavo...la mia è MAMP 1.7.1

fatto ma nada :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
antica bottega digitale
Jr. Member
 
Total Posts:  1
Joined:  2009-03-03
 

Salve a tutti.

sono fermo anche alla schermata di configurazione del wizard di installazione ogni volta che clico su avanti ritorna alla solita pagina senza dare nessun messaggio di errore, ho php apache mysql installati a mano sotto windows e nel log di apache non cè nessun errore.

Come completare l’installazione senza sapere dove cercare l’errore?!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Samuele
Jr. Member
 
Total Posts:  2
Joined:  2009-04-02
 

Ciao. Anche io lo stesso problema. Ho MAMP 1.7.1 su Leopard.

Ho provato a cambiare l’url in http://127.0.0.1:8888/magento/index.php/install/wizard/config/

ma alla conf mi viene ritornato questo errore:

*
o SQLSTATE[28000] [1045] Access denied for user ‘root’@’localhost’ (using password: NO)
o Database connection error

Non so che fare

 
Magento Community Magento Community
Magento Community
Magento Community
 
Samuele
Jr. Member
 
Total Posts:  2
Joined:  2009-04-02
 

Ho risolto. A posto.

Vi dico come ho fatto:

- reinstallato MAMP (1.7) ex novo;
- creato il db di prova;
- installato Magento;
- impostate le porte di default (Apache:80, Mysql:3306);
- ho dato per il db le credenziali di default (root/root)

That’s it smile !

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top