Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Category Pages not showing getting ‘404 Not Found’
 
Danielc1234
Sr. Member
 
Avatar
Total Posts:  175
Joined:  2008-01-09
Miami, FL - United States
 

I set up the demo store with no problems, or I think no problems.
Imported the sample database with no problems, but my category pages are not showing.
In the admin I can see that all the categorys are there, but they will not display on the store front side.

Any ideas why this is happening?

http://puppy-dog-beds.com/apparel

Thanks
Daniel

 
Magento Community Magento Community
Magento Community
Magento Community
 
Danielc1234
Sr. Member
 
Avatar
Total Posts:  175
Joined:  2008-01-09
Miami, FL - United States
 

Nevermind, I figured it out...in the category section (admin) the root was not defaulted to anything...had to set it to root category…

 
Magento Community Magento Community
Magento Community
Magento Community
 
zozza
Jr. Member
 
Total Posts:  7
Joined:  2008-02-08
 

..

 
Magento Community Magento Community
Magento Community
Magento Community
 
tridentsplash
Jr. Member
 
Total Posts:  5
Joined:  2007-11-07
 

Etiam auctor metus vel tellus iaculis, non vehicula est euismod. In consequat egestas mattis. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Cras vitae pulvinar libero. Vestibulum id ligula malesuada, elementum sapien sed, vehicula tortor. Etiam tempor nisi eu rutrum vehicula. Nullam massa nibh, laoreet nec tortor pretium, ultricies gravida tortor. Etiam ac purus quis lacus scelerisque sodales.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tehgamecat
Jr. Member
 
Total Posts:  27
Joined:  2007-09-12
 

exact same problem here

 
Magento Community Magento Community
Magento Community
Magento Community
 
timhill
Jr. Member
 
Total Posts:  4
Joined:  2009-09-24
 

My Category pages stopped working and decided to return a 404 page. I reset the Cache and checked all re-writes but nothing has changed. What had happened was I had set the page to ‘Display all’ and becuase there were to many products or something (still trying to work this part out) it decided to error. Hope this helps somebody.

 
Magento Community Magento Community
Magento Community
Magento Community
 
beveraii
Jr. Member
 
Total Posts:  10
Joined:  2009-01-17
Bristol, UK
 

I was having this problem.  Whenever I clicked on a product category I was getting a 404 Not Found page.

I managed to fix it (finally) by changing the ‘Category URL Suffix’ in Configuration > Catalog > Search Engine Optimisation.
I had ‘/’ as the suffix originally.  By removing this, to leave the input box empty, all my problems disappeared grin

Hope this helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
slunt32
Jr. Member
 
Total Posts:  6
Joined:  2010-08-31
 

I realise that this was posted a few months ago but I’ve search the internet for days on a solution to this an this worked straight away!

Ta very much!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top