Magento Forum

   
magento refuses to index
 
loganbest
Jr. Member
 
Total Posts:  8
Joined:  2011-05-26
 

Hi All,

I’m on a brand new FreeBSD 8.2 server with Magento 1.5.1.0. I have only 13 products in Magento (stock) and every time I try to reindex anything I get this: “… Index process is working now. Please try run this process later.” I have made sure the /var/locks directory is chmod 777 and read countless threads that just say to delete the lock files. Every time I delete the lock files and run the index again they recreate and don’t get deleted. This happens as well when I run

/shell/indexer.php reindexall
. The index in the DB will never get created and magento stays on “REINDEX REQUIRED”.

What can be done to fix this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Zurd
Member
 
Total Posts:  31
Joined:  2012-10-18
 

just a thought… what about if you try to reindex from the dashnoard ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
loganbest
Jr. Member
 
Total Posts:  8
Joined:  2011-05-26
 

If you’re talking about the Index Management page, yes. I ahve tried that. No Dice

 
Magento Community Magento Community
Magento Community
Magento Community
 
Zurd
Member
 
Total Posts:  31
Joined:  2012-10-18
 

might also want to flush everything in System / Cache Management and rm -fr var/cache/*

if it’s still not working, it’s possible there’s an error message somewhere, turn on debugging and check out the errors folder ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
loganbest
Jr. Member
 
Total Posts:  8
Joined:  2011-05-26
 

I have caching turned off, yet there’s still some cache files that show up in there “mage--[0-9a-z]”. Even if I clear them it doesn’t help the indexing and they come back immediately.

Also in ./var/log/system.log and exception.log there is nothing in them. I have made sure logging is turned on as well.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rkratt007
Jr. Member
 
Total Posts:  10
Joined:  2011-02-09
 

remove the var/locks var/cache var/tmp if there. Then retry the process. If you are still having this issue please post the error msg that is displayed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
loganbest
Jr. Member
 
Total Posts:  8
Joined:  2011-05-26
 

I have removed everything in /var. Clicked on a single “Reindex Data” link and immediately received this:

“Product Flat Data Index process is working now. Please try run this process later.”

The lock file persists and the flat data is not created.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jm_eklund
Jr. Member
 
Total Posts:  8
Joined:  2013-03-01
 

forgive me for my ignorance, but this is what it gives me when I try to execute that command.

-bash-3.2php indexer.php --reindexall
Content
-typetext/html

<br />
<
b>Parse error</b>:  syntax errorunexpected T_STRINGexpecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in <b>/home/content/04/10601804/html/shell/indexer.php</bon line <b>43</b><br />
-
bash-3.2$

Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
loganbest
Jr. Member
 
Total Posts:  8
Joined:  2011-05-26
 
jm_eklund - 22 March 2013 09:36 AM

forgive me for my ignorance, but this is what it gives me when I try to execute that command.

-bash-3.2php indexer.php --reindexall
Content
-typetext/html

<br />
<
b>Parse error</b>:  syntax errorunexpected T_STRINGexpecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in <b>/home/content/04/10601804/html/shell/indexer.php</bon line <b>43</b><br />
-
bash-3.2$

Any ideas?

You should probably replace that file with the stock indexer.php. It must’ve been edited at some point and someone forgot a bracket somewhere.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top