Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Uploading CSV file for shipping tablerates does nothing. 
 
kraj
Jr. Member
 
Total Posts:  9
Joined:  2008-10-21
Ireland
 

When I upload a csv file for weight based table rate shipping it doesn’t do anything. I don’t get any error message and the table doesn’t update in the Db. I’m just browsing, finding the file and then clicking ‘Save Config’… should there be a separate ‘Upload’ button or something?

See image attached.

It seems to be ignoring my file completely, without giving me any errors. Just incase it is a problem with the file though - here is what I’m using:

Country,Region/State,Zip/Postal Code,Order Subtotal (and above),Shipping Price
IRL,*,*,0.1,2.2
IRL,*,*,0.25,2.7
IRL,*,*,0.5,3.85
IRL,*,*,1,6
IRL,*,*,1.5,7.5
IRL,*,*,2,7.5
IRL,*,*,2.5,8.7
IRL,*,*,3,9.8
IRL,*,*,3.5,11
IRL,*,*,4,12
IRL,*,*,4.5,13
IRL,*,*,5,14
IRL,*,*,6,15
IRL,*,*,7,16
IRL,*,*,8,17
IRL,*,*,9,18
IRL,*,*,10,19
IRL,*,*,12,21
IRL,*,*,15,24
IRL,*,*,20,29

Any help would be much appreciated!

Image Attachments
my_csv_upload_page.gif
 
Magento Community Magento Community
Magento Community
Magento Community
 
kraj
Jr. Member
 
Total Posts:  9
Joined:  2008-10-21
Ireland
 

PROBLEM SOLVED
I’m adding this note incase anyone else has these problems.
This was solved by avoiding Microsoft Excel entirely. If I opened the file in Excel and made changes I assumed that if I re-saved the file in a plain text editor afterwards that it would be same as if I had edited it in plain text. Not so - my version of Excel obviously let some hidden characters or formatted it in a way that wasn’t compatible.

I downloaded the blank CSV shipping file from Magento, then opened it in a plain text editor and it worked fine. Avoid Excel completely.

 
Magento Community Magento Community
Magento Community
Magento Community
 
cedric31
Jr. Member
 
Total Posts:  4
Joined:  2009-01-06
 
kraj - 12 March 2009 09:37 AM

PROBLEM SOLVED
I’m adding this note incase anyone else has these problems.
This was solved by avoiding Microsoft Excel entirely. If I opened the file in Excel and made changes I assumed that if I re-saved the file in a plain text editor afterwards that it would be same as if I had edited it in plain text. Not so - my version of Excel obviously let some hidden characters or formatted it in a way that wasn’t compatible.

I downloaded the blank CSV shipping file from Magento, then opened it in a plain text editor and it worked fine. Avoid Excel completely.

I can confirm this: it’s best to avoid using Microsoft Excel when working with Magento’s .csv files.

Thanks for the tip.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mcSherpa
Member
 
Total Posts:  33
Joined:  2008-09-12
Groningen
 

The CSV files MicroSoft Excel produces, are not “real” CSV files. The field separator is not a comma and text strings are not surrounded by quotes. (It is an incompatible format by M$ again.)

OpenOffice Calc generates correct CSV files. Some people find it easier to work in a spreadsheet than in a text editor, especially if the files get longer.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lsitt
Jr. Member
 
Total Posts:  28
Joined:  2009-05-22
 

Not sure if this will help, but I’ve been trying to figure out how to upload my tax rates that are saved by Excel in CSV format for a bit now… after enough messing around with things I found that if I saved the Excel CSV file in CSV (Windows) format - (its further down the drop-down menu, not the CSV (Comma delimited)) it worked.  Another solution is to open the Excel saved CSV file in a text editor, delete the return funcion at the end of the line (so now both lines are on the first line) and press return again (now the lines are back where they should be) and do that for each line… Magento will sunddenly upload the files.  Strange, but it worked for me. 
I’m using a Mac and am running Excel 2004.
Hope it helps -

 
Magento Community Magento Community
Magento Community
Magento Community
 
margokahnrose
Jr. Member
 
Total Posts:  3
Joined:  2009-12-29
 

I was having the exact same issue and it was driving me nuts.  Here’s what finally worked - Working on a Mac, I opened my CSV (previously created in Excel) in TextWrangler.  The trick was NOT ONLY to change the line-breaks formatting to Unix in the preferences menu, but also upon re-saving the file. In TextWrangler, the Save-As dropdown contains a button for “Options.” In there, you can choose both your line breaks formatting (choose Unix) as well as Encoding (ignore, leave default).  Once I saved the file choosing the Unix setting in the saving options, Magento read my file, reflected upon exporting immediately after re-importing. 

BTW, putting in or omitting quotation marks, decimal points, etc. nor re-doing the line breaks in the text editor — none of that made any difference.  Only the above worked.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top