Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

After install using numerous workarounds, Warning: mysqli_stmt::bind_result() [function.mysqli-stmt-bind-result]: Server returned unknown type 246
 
karynn
Member
 
Avatar
Total Posts:  70
Joined:  2008-02-07
 

Test site: danielandkarynn.com/magento
Shared Hosting, powweb.com
Magento Version: 0.7.15480
MySQL Version:  5.0.45
PHP Version: 5.2.2
Zend Version: 2.5.7

Workarounds needed during install:
- PHP4, due to pdo_mysql issue
- app/etc/config.xml: changed all references of <type>pdo_mysql</type> to <type>mysqli</type> (thanks Moshe)
- app/code/core/Mage/Install/etc/install.xml remove line that contains <pdo_mysql/> (thanks Moshe)
During install, hit yet another error after entering Database details: Fatal error: Call to a member function getClassName() on a non-object in /home/testing/web/public/magento/app/code/core/Mage/Core/Model/Resource.php on line 92

I couldn’t find a solution, so I tried updating the app/etc/config.xml as shown below—but I have no idea what I am doing, so thought someone may know why this was or was not a good change:
From

<resource>
            <
connection>
                <
types>
                    <
pdo_mysql>
                        <class>
Mage_Core_Model_Resource_Type_Db_Pdo_Mysql</class>
                    </
pdo_mysql>
                </
types>
            </
connection>
        </
resource>
To
<resource>
            <
connection>
                <
types>
                    <
mysqli>
                        <class>
Mage_Core_Model_Resource_Type_Db_Mysqli</class>
                    </
mysqli>
                    <
pdo_mysql>
                        <class>
Mage_Core_Model_Resource_Type_Db_Pdo_Mysql</class>
                    </
pdo_mysql>
                </
types>
            </
connection>
        </
resource>
This got me through the next steps of the install and it said it finished (although timed out after I clicked next after entering db details, I clicked refresh and it went to the next page of the installer).

When I go to the admin area, I see this error message under Number of Orders tab:

Warningmysqli_stmt::bind_result() [function.mysqli-stmt-bind-result]Server returned unknown type 246. Probably your client library is incompatible with the server version you use! in /hermes/web04/b1842/pow.karynn/htdocs/magento/lib/Zend/Db/Statement/Mysqli.php on line 227
[0] in mysqli_stmt
->bind_result(000NULL00NULLNULL0NULLNULLNULLNULLNULL)
[1] in call_user_func_array(Array[2]Array[14]in /hermes/web04/b1842/pow.karynn/htdocs/magento/lib/Zend/Db/Statement/Mysqli.php on line 227
[2] in Zend_Db_Statement_Mysqli
->_execute(Array[0]in /hermes/web04/b1842/pow.karynn/htdocs/magento/lib/Zend/Db/Statement.php on line 279
[3] in Zend_Db_Statement
->execute(Array[0]in /hermes/web04/b1842/pow.karynn/htdocs/magento/lib/Zend/Db/Adapter/Abstract.php on line 396
[4] in Zend_Db_Adapter_Abstract
->query(Zend_Db_SelectArray[0]in /hermes/web04/b1842/pow.karynn/htdocs/magento/lib/Zend/Db/Adapter/Abstract.php on line 603
[5] in Zend_Db_Adapter_Abstract
->fetchAll(Zend_Db_Selectin /hermes/web04/b1842/pow.karynn/htdocs/magento/app/code/core/Mage/Eav/Model/Entity/Collection/Abstract.php on line 928
[6] in Mage_Eav_Model_Entity_Collection_Abstract
->_loadEntities(, ) in /hermes/web04/b1842/pow.karynn/htdocs/magento/app/code/core/Mage/Eav/Model/Entity/Collection/Abstract.php on line 782
[7] in Mage_Eav_Model_Entity_Collection_Abstract
->load() in /hermes/web04/b1842/pow.karynn/htdocs/magento/app/code/core/Mage/Adminhtml/Helper/Dashboard/Order.php on line 39
[8] in Mage_Adminhtml_Helper_Dashboard_Order
->_initCollection() in /hermes/web04/b1842/pow.karynn/htdocs/magento/app/code/core/Mage/Adminhtml/Helper/Dashboard/Abstract.php on line 47
[9] in Mage_Adminhtml_Helper_Dashboard_Abstract
->getCollection() in /hermes/web04/b1842/pow.karynn/htdocs/magento/app/code/core/Mage/Adminhtml/Helper/Dashboard/Abstract.php on line 61
[10] in Mage_Adminhtml_Helper_Dashboard_Abstract
->getItems() in /hermes/web04/b1842/pow.karynn/htdocs/magento/app/code/core/Mage/Adminhtml/Helper/Dashboard/Abstract.php on line 66
[11] in Mage_Adminhtml_Helper_Dashboard_Abstract
->getCount() in /hermes/web04/b1842/pow.karynn/htdocs/magento/app/code/core/Mage/Adminhtml/Block/Dashboard/Tab/Abstract.php on line 48
[12] in Mage_Adminhtml_Block_Dashboard_Tab_Abstract
->getCount() in /hermes/web04/b1842/pow.karynn/htdocs/magento/app/design/adminhtml/default/default/template/dashboard/tab/graph.phtml on line 22
[13] in 
include("/hermes/web04/b1842/pow.karynn/htdocs/magento/app/design/adminhtml/default/default/template/dashboar"in /hermes/web04/b1842/pow.karynn/htdocs/magento/app/code/core/Mage/Core/Block/Template.php on line 122
[14] in Mage_Core_Block_Template
->fetchView("adminhtml/default/default/template/dashboard/tab/graph.phtml"in /hermes/web04/b1842/pow.karynn/htdocs/magento/app/code/core/Mage/Core/Block/Template.php on line 153
[15] in Mage_Core_Block_Template
->renderView() in /hermes/web04/b1842/pow.karynn/htdocs/magento/app/code/core/Mage/Core/Block/Template.php on line 198
[16] in Mage_Core_Block_Template
->toHtml() in /hermes/web04/b1842/pow.karynn/htdocs/magento/app/design/adminhtml/default/default/template/dashboard/tab/bar.phtml on line 43
[17] in 
include("/hermes/web04/b1842/pow.karynn/htdocs/magento/app/design/adminhtml/default/default/template/dashboar"in /hermes/web04/b1842/pow.karynn/htdocs/magento/app/code/core/Mage/Core/Block/Template.php on line 122
...

Any ideas?
Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top