Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Cant get beyond database connection screen - no errors
 
Raptor Commerce (toby)
Sr. Member
 
Total Posts:  180
Joined:  2009-01-31
 

I am trying to install the latest version of Magento (using the downloader). I am stuck on the database connection screen. I am asked for the database details but when I click continue I am returned to the same screen but my database settings are replaced by the magento defaults. I’m not getting any errors - I just cant get beyond this screen :-(

Does anyone know what could be causing this?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
WebShopApps
Guru
 
Avatar
Total Posts:  460
Joined:  2008-05-30
London, UK
 

See this thread:

http://www.magentocommerce.com/boards/viewthread/30715/P60/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sajeev
Jr. Member
 
Total Posts:  2
Joined:  2009-02-02
 

Hey:

This is because the latest version verifies whether your MuSQL supports the InnoDB version. If you are using xampp, edit the xampp\mysql\bin\my.conf file and
1. Comment the below line (see the # in the beginning):
#skip-innodb

2. uncomment (remove #) the folowing lines:
innodb_data_home_dir = “C:/xampp/mysql/data/”
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = “C:/xampp/mysql/data/”
innodb_log_arch_dir = “C:/xampp/mysql/data/”
## You can set .._buffer_pool_size up to 50 - 80 %
## of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 50M
innodb_additional_mem_pool_size = 10M
## Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

you should be able to proceed now..

sajeev

 
Magento Community Magento Community
Magento Community
Magento Community
 
Raptor Commerce (toby)
Sr. Member
 
Total Posts:  180
Joined:  2009-01-31
 

Thanks Sanjeev ... i’m not using XAMP, my test box is an OS X machine and production is Solaris. What exactly is the problem the installer encounters? I am using InnoDB tables without any problems with my other applications so I know InnoDB is set up.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
smart1234
Jr. Member
 
Total Posts:  15
Joined:  2009-02-23
 

I m still having the same problem even after following the steps provided by Sajeev.....  can anyone pls help me out

 
Magento Community Magento Community
Magento Community
Magento Community
 
denmic
Jr. Member
 
Total Posts:  22
Joined:  2008-05-16
 

I was just experiencing the same problem as you described on my local dev system (Ubuntu LAMP). My first thought was to switch to an older version (1.2.0.3) instead of installing the latest release and update afterwards. When trying to install the old release there was suddenly an error on the DB configuration page complaining about “invalid url” in base URL configuration. After checking “Skip Base URL validation before next step” the installer ran smoothly. Just to double check the problem I deleted the DB and code again and reran the installer with the latest code. Suprisingly now there was the same error message (I guess this might have something to do with session handling as I didn’t close the browser between the 2 installations). So to solve your problem try to check the “Skip Base URL validation before next step” and see if it will install…

 
Magento Community Magento Community
Magento Community
Magento Community
 
denmic
Jr. Member
 
Total Posts:  22
Joined:  2008-05-16
 

Sorry, posted in wrong thread…

 
Magento Community Magento Community
Magento Community
Magento Community
 
smart1234
Jr. Member
 
Total Posts:  15
Joined:  2009-02-23
 

But I m not getting any type of errors......
I am redirected on the page of database connection again and again.....

 
Magento Community Magento Community
Magento Community
Magento Community
 
denmic
Jr. Member
 
Total Posts:  22
Joined:  2008-05-16
 

Did you try to check “Skip Base URL validation before next step” ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
robojockitch
Jr. Member
 
Total Posts:  2
Joined:  2009-02-27
 

I’m also having this problem.  Can’t get past the db connection screen, but no errors.  And yes I’ve tried checking “Skip Base URL validation before next step”, but that hasn’t helped.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ckosny
Guru
 
Total Posts:  349
Joined:  2009-02-28
Luxembourg
 

I had the same problem.

Turned out that my mysql version was not up to date (I had 4.1.14 instead of the required 4.1.20).
No idea why I did not get any error message though.

Good luck

Claudia

 
Magento Community Magento Community
Magento Community
Magento Community
 
snyderpa
Jr. Member
 
Total Posts:  2
Joined:  2009-02-26
 

I had this problem.

On line 302 of magento/app/code/core/Mage/Install/controllers/WizardController.php I found the function configPostAction() and inserted the debugging statements:

var_dump($e);
exit;

into the catch block of the try/catch.

This revealed to me that I was in fact having a failure to connect to my database which was not being reported visually by the form.

 
Magento Community Magento Community
Magento Community
Magento Community
 
robojockitch
Jr. Member
 
Total Posts:  2
Joined:  2009-02-27
 

Figured out my problem.  I didn’t pay enough attention reading the install instructions.

To c:/windows/system32/drivers/etc/hosts file add the entry:

127.0.0.1 http://www.localhost.com

Then access the install as http://www.localhost.com/magento
*NOT* http://localhost/magento

Otherwise your browser will hate you -> according to the install instructions your browser won’t accept cookies directly from localhost so you have to trick it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
nextyoficial
Jr. Member
 
Total Posts:  1
Joined:  2014-06-09
 
snyderpa - 28 February 2009 04:53 PM

I had this problem.

On line 302 of magento/app/code/core/Mage/Install/controllers/WizardController.php I found the function configPostAction() and inserted the debugging statements:

var_dump($e);
exit;

into the catch block of the try/catch.

This revealed to me that I was in fact having a failure to connect to my database which was not being reported visually by the form.

In my case I have uncommented extension = php_pdo_mysql.dll on my php for windows and started to work

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top