Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Export products “Fatal error: Maximum execution time of 60 seconds exceeded”
 
Technical Advice
Jr. Member
 
Total Posts:  6
Joined:  2009-01-11
 


I have just imported another 1200 items to my website (using the import all profile) so the total number of products I now have is now over 4000.

Once the import process was completed (which took 2 1/2 hours) I was unable to export all products! I got the following message: -

Fatal error: Maximum execution time of 60 seconds exceeded in /home/technic2/public_html/app/code/core/Mage/Eav/Model/Entity/Attribute/Backend/Abstract.php on line 155

I have had no issues before doing this, everything has been working fine.

Any help from you guys would be amazing!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 
Technical Advice - 06 February 2009 10:14 AM


Fatal error: Maximum execution time of 60 seconds exceeded in /home/technic2/public_html/app/code/core/Mage/Eav/Model/Entity/Attribute/Backend/Abstract.php on line 155

Hello,

The error you are receiving most likely has to do with your php configuration.  Larger catalogs require longer timeout settings for these large operations to fully complete.

If you do not have access to the servers php.ini file, ask that the host increase the ‘max_execution_time’ to a value of 1800 - this is 30 minutes and should be enough time for most large catalogs.

If the host is using the PHP Module Suhosin the timeout configuration settings there may be overriding the settings in your .htaccess or your server does not allow overriding of these values.

Hope this helps~

 
Magento Community Magento Community
Magento Community
Magento Community
 
Technical Advice
Jr. Member
 
Total Posts:  6
Joined:  2009-01-11
 

OK, thanks for this! I have asked web host to change as sugguested, will update this post when it’s done. Thanks again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Technical Advice
Jr. Member
 
Total Posts:  6
Joined:  2009-01-11
 

My hosting company wouldn’t increase it to that extent (1800) as it is a shared host package I am on. However they did say they have increase it a little. Even though they have increased it I still get a 60 second error! Is there anything else I can do?

Fatal error: Maximum execution time of 60 seconds exceeded in /home/technic2/public_html/lib/Zend/Db/Select.php on line 984

Any sugguestions would be much appreciated.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 

Would it be possible for you to create a phpinfo file and post the URL here? 

This may help to diagnose the problem and to verify that the changes have been made.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Technical Advice
Jr. Member
 
Total Posts:  6
Joined:  2009-01-11
 

http://www.technicalcomparison.co.uk/phpinfo.php

And looking at the max_execution_time it is still 60! So I will email my host again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 

Ok, thanks-

A couple observations -

1. max_execution_time == 60 (this value has not been changed according to your phpinfo file)

2. your system is running in fcgi mode - In this case, you are likely hitting some fcgi timeout settings. 

You can request that your host apply the following fCGI configuration changes to your account;

IPCCommTimeout 1800
BusyTimeout 1800

Unfortunately, given the results of number 1 above you may have mixed results on this request.

I hope this helps

 
Magento Community Magento Community
Magento Community
Magento Community
 
Technical Advice
Jr. Member
 
Total Posts:  6
Joined:  2009-01-11
 

Many thanks, my web host has increased the time to 120 seconds, which has resolved the issue for now.

I will be adding even more products to my site over the coming weeks, which means this issue will come back, so I will have to search out another web host in the UK.

Thanks again for you advice, really appreciated!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 

My pleasure to help -

Glad your host properly made the change so that you could confirm the problem and resolution.

As you add more products to the cart there are going to be other timeouts that you are going to want to look at, depending on your hosting environment.  If you can, it’ll be best to go with a host that has some working knowledge of Magento as these will likely already be setup correctly for you.

There’s a lot of hosts to choose from on this page; http://www.magentocommerce.com/wiki/general/magento-web-hosting but be sure to ASK QUESTIONS as it doesn’t take anything to get on that list other than editing the page and adding your business.

If you’re looking for a list of questions to ask prospective hosts, I’d start at the top of the system requirements and work down, ending with asking for a demo store to run through.

Best of luck with everything.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hipgirl
Jr. Member
 
Total Posts:  1
Joined:  2011-01-24
 

Hello,

I got the same error message.

Fatal error: Maximum execution time of 30 seconds exceeded in .../public_html/.../magento/app/code/core/Mage/Catalog/Model/Convert/Parser/Product.php on line 424

I’ve changed the max_execute_time to 360 but still got the error above.

Thank you much for help.

Michelle

 
Magento Community Magento Community
Magento Community
Magento Community
 
ct.cc
Jr. Member
 
Total Posts:  3
Joined:  2011-01-17
 

Me too I have the same problem…
Any one Can be help??
Thanks lot…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 
ct.cc - 11 March 2011 01:58 AM

Me too I have the same problem…
Any one Can be help??
Thanks lot…

You ‘may’ be able change the max_execution_time of PHP by addition the following directive to your .htaccess file;

php_value max_execution_time = 180 (set to your necessary value <in seconds>

You can then verify this setting by creation a PHPInfo page - phpinfo(); and looking for the max_execution_time value.

If your value has not changed then you both should check with your host to see if they have an alternative way of raising the php value of max_execution_time to your required value.

Hope this helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ct.cc
Jr. Member
 
Total Posts:  3
Joined:  2011-01-17
 

Hey Thanks lot for your help…
Now I tested and the page dont show me “Fatal error: Maximum execution time of 60 seconds exceeded” this message any more..

But when the page finish work..  (I can see the page work process 100% done)

The page still like working as before..  I wait more 2 hours but the page is same..  And I checked the export date there is empty..
But the page Im sure is already work process 100% done.... I tried via many Browsers, they are same problem

After I tested again at night 5 hours used… Also same.. there no change at the page but work process is done…

Now How can I do??  Thanks lot for everyone’s help smile
Hope we can Share experiences

Cheers

PS: Screenshot is when the page page work process 100% done…

Image Attachments
2011-03-12_170433.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
ct.cc
Jr. Member
 
Total Posts:  3
Joined:  2011-01-17
 

PS: .htaccess file & php.ini I all changed the max_execution_time & php_value max_execution_time

Image Attachments
2011-03-12_170433.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
matrixbegins
Jr. Member
 
Total Posts:  11
Joined:  2010-02-17
 

ok guys here is all the things but its not helping me.

I have increased the max_execution_time to 1800 in my php.ini & in my .htaccess it is 18000

but still I am having the same error.

I also have cros checked my phpinfo & it verifies the above values

Can u help me with this ??

thanks
SAM

 
Magento Community Magento Community
Magento Community
Magento Community
 
gindib
Jr. Member
 
Total Posts:  7
Joined:  2009-11-24
 

You can also try this if you don’t want to mess with ini files.

Place this within the index.php file of your magento install…

ini_set(’max_execution_time’,’1800’);

Just in case, for memory limit, you can use…

ini_set(’memory_limit’,’1024M’);

Worked easy for me when I imported 30k+ rows.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2