Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

API “product.info” call doesn’t work with SKU
 
Corllete Ltd
Member
 
Avatar
Total Posts:  47
Joined:  2007-11-08
Bulgaria
 

Hi all. When I try this with magento api

$proxy->call($sessionId'product.info''sku_of_product')

i get

ErrorSoap Fault ReasonProduct not exists.Soap Fault Code101

The above call is only working when I pass an ID of a product eg:

$proxy->call($sessionId'product.info''product_id')

Any advice?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Nizumzen
Jr. Member
 
Total Posts:  26
Joined:  2008-12-07
 

Sounds like you are entering the wrong SKU. Are you sure you have typed it in correctly and with all the correct capitalisation?

Edit: Have you tried using the full name version of the method? catalog_product.info

 
Magento Community Magento Community
Magento Community
Magento Community
 
Corllete Ltd
Member
 
Avatar
Total Posts:  47
Joined:  2007-11-08
Bulgaria
 

I have tried everything before posting my question. Yes I’m sure that I have entered the correct SKU (in my case 12 - this can’t be misspelled ).

BTW: Same for

$proxy->call($sessionId'product.update', array('sku_of_product', array('name'=>'new name of product'), 'german')
);
 
Magento Community Magento Community
Magento Community
Magento Community
 
Corllete Ltd
Member
 
Avatar
Total Posts:  47
Joined:  2007-11-08
Bulgaria
 

BUMP

no one with answer here.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Corllete Ltd
Member
 
Avatar
Total Posts:  47
Joined:  2007-11-08
Bulgaria
 

"If you can’t help your self then God can’t help you too !!!” (An old Bulgarian proverb.)

Solution here

http://www.magentocommerce.com/boards/errors.php/viewthread/12510/

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top