Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Regole prodotti catalogo
 
ruxfabio
Jr. Member
 
Total Posts:  21
Joined:  2013-02-01
 

Salve a tutti. Sono sicuro che è un errore stupido, ma non riesco a venirne a capo.

Ho impostato una regola sui prodotti di tutto il catalogo. Un -10% per un mese.
Dopo un paio di giorni alcuni prodotti hanno ancora questa regola applicata, altri no.
Alcuni prodotti nella lista della categoria mantengono la regola applicata, ma poi quando vado nel dettaglio di quel prodotto la regola si perde.
Insomma un po’ variegato.
Di sicuro quando inserisco un qualunque prodotto del carrello esso non mantiene la regola (nel caso la avesse mantenuta mentre lo visualizzavo).

Devo riapplicare la regola da back-end e fare un refresh della cache per vedere tutto correttamente per un altro paio di giorni.

Il cron parte ogni 30 minuti.
Non ho impostato l’opzione Catalogo flat nè per le categorie, nè per i prodotti.
Ho la versione 1.7.

Grazie, fabio.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ruxfabio
Jr. Member
 
Total Posts:  21
Joined:  2013-02-01
 

Il problema si è ripresentato dopo meno di un giorno e mezzo.
Di nuovo i prezzi tornano senza la regola applicata o nel carrello o nel dettaglio del prodotto stesso.

Pensate possa essere qualcosa del Cron pur se viene eseguito ogni 30 minuti ?
Ho visto che altri avevano un problema similare e veniva risolto col Cron attivato, ma io già ce l’ho attivo.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ruxfabio
Jr. Member
 
Total Posts:  21
Joined:  2013-02-01
 

UPDATE.

Il cron viene eseguito correttamente, infatti non ho log di errori.
Però sicuramente non funziona bene. Ho controllato in report->Vendite->Ordini e mi appare la dicitura “undefined” dopo “ultimo aggiornamento”.

Quindi se il cron parte ma non funziona correttamente, il problema deve essere in cosa fa il cron.
Devo modificare qualcosa al suo interno o nelle impostazioni da back-end ?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top