Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

There has been an error processing your request
 
bodist
Jr. Member
 
Total Posts:  1
Joined:  2012-12-18
 

Hallo zusammen,
ich bin gerade dabei meinen ersten Magento-Shop aufzusetzen und an sich auch ganz gut vorangekommen.
Nun habe ich einen merkwürdigen Fehler, wenn mehr als ein Artikel im Warenkorb liegt und ich eine Detailseite eines Artikels aufrufe, bei dem Zubehör hinterlegt ist.

Die Fehlermeldung lautet:

There has been an error processing your request
SELECT 
`e`.*, `price_index`.`price`, `price_index`.`tax_class_id`, `price_index`.`final_price`, IF(price_index.tier_price IS NOT NULLLEAST(price_index.min_priceprice_index.tier_price), price_index.min_price) AS `minimal_price`, `price_index`.`min_price`, `price_index`.`max_price`, `price_index`.`tier_price`, `cat_index`.`position` AS `cat_index_position`, `links`.`link_id`, `link_attribute_position_int`.`value` AS `positionFROM `catalog_product_entity` AS `e`
 
INNER JOIN `catalog_product_index_price` AS `price_indexON price_index.entity_id e.entity_id AND price_index.website_id '3' AND price_index.customer_group_id 0
 INNER JOIN 
`catalog_category_product_index` AS `cat_indexON cat_index.product_id=e.entity_id AND cat_index.store_id='2' AND cat_index.visibility IN(24) AND cat_index.category_id='4'
 
INNER JOIN `catalog_product_link` AS `linksON links.linked_product_id e.entity_id AND links.link_type_id 1
 LEFT JOIN 
`catalog_product_link_attribute_int` AS `link_attribute_position_intON link_attribute_position_int.link_id links.link_id AND link_attribute_position_int.product_link_attribute_id '1' WHERE (e.entity_id NOT IN((SELECT `sales_flat_quote_item`.`product_idFROM `sales_flat_quote_itemWHERE (quote_id '209')))) AND (links.product_id 388) AND (`e`.`entity_id` != '388'ORDER BY `positionASC



Trace
:
#0 /www/htdocs/w008ec85/magento/lib/Varien/Db/Statement/Pdo/Mysql.php(110): Zend_Db_Statement_Pdo->_execute(Array)
#1 /www/htdocs/w008ec85/magento/lib/Zend/Db/Statement.php(300): Varien_Db_Statement_Pdo_Mysql->_execute(Array)

An sich ist das meines Erachtens auch kein Fehler, sondern eher eine normale SQL-Anfrage grin

Foren- und Internetsuche ergaben leider auch nicht viel, habe bis jetzt lediglich gefunden, dass jemand anderes das gleiche Problem hatte:
http://www.magentocommerce.com/boards/index.php/viewthread/300655/#t418256

Für Eure Hilfe wäre ich dankbar
Besten Gruß
Matthias

 
Magento Community Magento Community
Magento Community
Magento Community
 
Darokthar
Jr. Member
 
Total Posts:  10
Joined:  2012-08-21
 

Das Problem hatte ich auch. Soweit ich das verstehe war das ein Problem, dass ein Modul versucht die Datenbankabfrage falsch zu erstellen. Und zwar werden die falschen klassen genutzt. Ich meine das Problem war Paypal, oder PAYONE.

Da ich beide nicht brauche, habe ich die einfach deaktiviert in der Konfiguration -> Erweitert -> Erweitert.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top