Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

[SOLUCIONADO] Configuração mail() via htaccess, erro de cabeçalho HTTP
 
paulovjcastilho
Jr. Member
 
Total Posts:  1
Joined:  2013-01-05
 

Saudações,

Estava quebrando a cabeça com um problema que aparecia em minha instalação do Magento, rodando em um servidor Hostnet.
Cheguei a abrir um tópico para encontrar a solução, mas antes disso tropecei nela. Quero deixar aqui registrado para quem passar pela mesma situação. O problema é o seguinte, ao configurar a função mail() do PHP via arquivo .htaccess, como explicado no wiki da Hostnet, podemos encontrar o seguinte relatório de erro ao tentar enviar e-mails pelo Magento:

Cannot send headers; headers already sent

Seguido de uma série de caminhos para arquivos dentro do Magento, em especial o arquivo Sendmail.php.

Esse erro nos informa que cabeçalhos HTTP já foram enviados para o navegador, impedindo que outros scripts envolvidos no processo funcionem corretamente. Pesquisando no Google podemos encontrar diversas explicações sobre caracteres inválidos em locais não permitidos, scripts escritos incorretamente e etc. De fato, neste caso existem caracteres intrusos atrapalhando o funcionamento do Magento, mas não estão em nenhum script da aplicação.

A questão é que a configuração da função mail() via arquivo .htaccess fornece a opção de debug do processo de envio

php_flag.authmail.debug ON

A linha acima gera uma saída HTTP que provoca o erro citado. Para solucionar este problema, basta modificar a linha acima para

php_flag authmail.debug OFF

Dessa maneira, o Magento deve enviar e-mails sem erros.

 
Magento Community Magento Community
Magento Community
Magento Community
 
shera007
Jr. Member
 
Total Posts:  1
Joined:  2014-03-03
 

friend

Had the same problem. I asked the support that arrumassem, but very slow.

It worked here too.

Many thanks for the help.

Hug!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top