Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

pas de retour suite à paiement ATOS/SIP
 
jphb
Jr. Member
 
Total Posts:  8
Joined:  2011-02-07
 

Bonjour

Alors que mon site marche depuis plusieurs années, depuis quelques jours, toutes les nouvelles commandes sont bien enregistrées, le client recoit bien un mail, mais aucun retour banque dans le backoffice.
J’ai bien regardé les fichiers certif & Co, pas modifiés depuis 3 ans, idem pour le fichier response et request. Les droits d’accès à ces fichiers sont bien toujours à 755…

Auriez-vous une idée de ce qui pourrait poser problème ?

Cordialement

 
Magento Community Magento Community
Magento Community
Magento Community
 
bloggento
Enthusiast
 
Total Posts:  850
Joined:  2009-09-23
 

Bonjour,
étrange ton problème. Regarde si ton serveur est pas full. Vérifie les liens vers les chemins response et request dans le back offiice et sur le ftp Demande aussi à ton hébergeur s’il n’a pas changé de serveur ou fait une modification sur ton serveur.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jphb
Jr. Member
 
Total Posts:  8
Joined:  2011-02-07
 

J’ai fait un gros menage mais ce n’est pas mieux, de toute manière il en restait quand même beaucoup.

Concernant le chemin, il n’a pas été modifié et il est bon. N’y aurait-il pas un log qui permettrait de connaitre le problème ?

Le serveur est un RPS chez OVH, je suis sensé être le seul à y faire des modifs…

Complément…

Je viens de trouver une erreur dans un fichier error_log.log juste au moment du passage d’une commande

[error] [client xx.xx.xx.47] File does not exist: /home/xxxxxxxxxxx/www/skin/frontend/default/default/css/stylesheet.css, referer: http://www.laboutiquedoptique.com/atos/standard/redirect/
[error] [client xx.xx.xx.47] File does not exist: /home/xxxxxxxxxxx/www/skin/frontend/default/default/css/checkout.css, referer: http://www.laboutiquedoptique.com/atos/standard/redirect/

Effectivement ces css n’existent pas. effectiement aussi sous www/app/code/local/Mage/Atos/Block/Standard le fichier redirect.php non modifié depuis octobre 2009 (Sic!) contient
$html.= ‘ @import url(“‘.$this->getSkinUrl(’css/stylesheet.css’).’");’."\n";
$html.= ‘ @import url(“‘.$this->getSkinUrl(’css/checkout.css’).’");’."\n";

Cela peut-il être la cause du problème ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ArthurCarayon
Jr. Member
 
Total Posts:  7
Joined:  2010-04-27
 

Je ne pense pas que le problème vienne de là. Nous tournons en rond de notre côté, on a exactement le même problème, du jour au lendemain sans qu’on ai touché quoi que ce soit, plus rien, toutes les commandes étaient en statut “nouveau” ou “annulé”.

On a vérifié auprès d’OVH qu’il n’avait pas fait d’opération. On a reboot. Vider les caches/sessions/locks. Toujours rien.
Et pire encore sur notre preprod installé sur le même serveur, tout fonctionne avec un code identique… incompréhensible.

Si quelqu’un a une idée, ou même une solution, surtout qu’il n’hésite pas !
Merci ! smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
jpbauer
Sr. Member
 
Total Posts:  159
Joined:  2008-10-09
Paris IDF
 

Bonjour

Effectivement le problème vient pas de là mais d’un fichier journal (I/O) mysql pour les tables innodb (je ne me souviens plus où il est exactement mais son nom était quelque chose comme “ibdata1"). J’ai du sauvegardé la base. Vider la base. Supprimer le fichier. Réimporter la sauvegarde

Effet immédiat

Cordialement

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top