Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PHP Fatal error:  Call to a member function getConfig()
 
JoernBernd
Member
 
Total Posts:  46
Joined:  2011-11-17
 

Hallo zusammen,

wir setzen das Modul “FME_Faqs” in unserem Shop ein. Wenn man jetzt eine FAQ bearbeiten will, gibt es die Fehlermeldung:

PHP Fatal error:  Call to a member function getConfig() on a non-object in /.../app/code/local/FME/Faqs/Block/Adminhtml/Faqs/Edit/Tab/Form.php on line 66, referer: .../index.php/faqsadmin/adminhtml_faqs

Wenn ich die Zeilen

try{
            $config 
Mage::getSingleton('cms/wysiwyg_config')->getConfig(
                array(
                        
'add_widgets' => false,
                        
'add_variables' => false,
                    )
                );
            
$config->setData(Mage::helper('faqs')->recursiveReplace(
                        
'/faqs/',
                        
'/'.(string)Mage::app()->getConfig()->getNode('admin/routers/adminhtml/args/frontName').'/',
                        
$config->getData()
                    )
            );
        
}
        
catch (Exception $ex){
            $config 
null;
        
}
entferne, kann ich zumindest wieder die FAQs bearbeiten.

Mir ist klar, dass hier kein Support für die Module anderer gegeben wird, aber vielleicht kennt jemand die Fehlermeldung und kann etwas dazu sagen, wo der Fehler liegt.

Ich bin für jeden Tipp dankbar.

---
Magento Version 1.3.2.4

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siggi_Schmitz
Enthusiast
 
Avatar
Total Posts:  811
Joined:  2011-07-03
 

1) Ist die Fehlermeldung in dieser Zeile?

$config = Mage::getSingleton(’cms/wysiwyg_config’)->getConfig

2) Du benutzt Magento 1.3.2.4, ist die Extension für diese Version geeignet? Schau mal nach..

 
Magento Community Magento Community
Magento Community
Magento Community
 
JoernBernd
Member
 
Total Posts:  46
Joined:  2011-11-17
 

Hallo Siggi,

danke für eine Antwort.

1) Ist die Fehlermeldung in dieser Zeile?

Ja

2) Du benutzt Magento 1.3.2.4, ist die Extension für diese Version geeignet? Schau mal nach..

Die Frage ist berechtigt, aber die Extension ist schon seit langem installiert und sollte auch mit der Magento Version kompatibel sein. Der Fehler tritt erst jetzt auf. Vorher lief es.
Warum es jetzt nicht mehr geht, kann ich nicht sagen.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siggi_Schmitz
Enthusiast
 
Avatar
Total Posts:  811
Joined:  2011-07-03
 

Hmm, existiert denn die Datei app/code/core/Mage/Cms/Model/Wysiwyg/Config.php bei dir?

 
Magento Community Magento Community
Magento Community
Magento Community
 
JoernBernd
Member
 
Total Posts:  46
Joined:  2011-11-17
 

Hallo Siggi,

danke für deine Antwort.

existiert denn die Datei app/code/core/Mage/Cms/Model/Wysiwyg/Config.php bei dir?

Nein, die Datei existiert nicht.

Kann ich den Wysiwyg für 1.3.2.4 nachinstallieren/aktivieren? Wahrscheinlich nur als Modul, oder?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top