Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Weird Register at Checkout Redirects back to Cart. 
 
paradigmtest
Jr. Member
 
Total Posts:  27
Joined:  2011-08-18
 

I’m getting a really weird error when a customer lands on the one page checkout, then clicks the “Register” for a new account, the page loads (showing the Registration form), then forwards them back to the Cart page.

You can try it out for yourself:
1. Go to http://207.32.184.10/store/long-sleeve-red-trout.html
2. Add to cart.
3. Click “Proceed to Checkout”
4. Click “Register”
(this should show the register form, then forward you to the cart page.)

To be even more specific: The Register form appears, the side menu disappears, sometimes a whole other “Page Not Found” page loads in the side menu, then it puts them back on the home page.

Anyone have any ideas?

P.S. I’m using Magento Community 1.7.0.2.

 
Magento Community Magento Community
Magento Community
Magento Community
 
peterfr
Jr. Member
 
Total Posts:  1
Joined:  2012-05-21
 

We got the same error last week on our test site. Also working on 1.7.0.2. We are still looking for a solution. We have installed the the fishpig wordpress extension, but even after disabling it, problem still there.

 
Magento Community Magento Community
Magento Community
Magento Community
 
paradigmtest
Jr. Member
 
Total Posts:  27
Joined:  2011-08-18
 

Thanks. Figured it out.

I had the \"Facebook Connect and Like Free\” module installed and it was not reacting well to the checkout (even though it was disabled).

http://www.magentocommerce.com/magento-connect/facebookfreebelvg-4448.html

Not sure if this was an issue with the module, the module and 1.7, or just my set up of Magento/template. But I removed it and it fixed the issue.

 
Magento Community Magento Community
Magento Community
Magento Community
 
syncddesign
Jr. Member
 
Total Posts:  21
Joined:  2011-10-16
 

I have the same problem and i also have the FB plugin, i have remove the plugin and flushed everything and it still not working.
don’t think its the fb plugin… any more help

 
Magento Community Magento Community
Magento Community
Magento Community
 
sterfrydude
Jr. Member
 
Total Posts:  2
Joined:  2012-10-22
 

I have the same issue with this on 1.8.1. We do not have the facebook plugin mentioned. Any more updates on this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
VAGLER
Jr. Member
 
Total Posts:  6
Joined:  2014-01-23
 

I had the same problem on v1.8.1 after enabling “Require Customer To Be Logged In To Checkout” under “System > Configuration > Checkout > Checkout Options”

Selecting this option to “No” fixed the problem for me.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top