Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problems with System COnfiguration after Update 1.2.1
 
28spin
Jr. Member
 
Total Posts:  12
Joined:  2008-09-22
 

After updating my magento to 1.2.1, i get this problem when i click SYSTEM > Configuration.

can anyone help?

Warning: include(Mage/Adminhtml/Model/System/Config/Source/Locale/Weekdays.php[function.include]failed to open streamNo such file or directory  in /home/24836/domains/28spin.com/html/app/code/core/Mage/Core/functions.php on line 73

#0 /home/24836/domains/28spin.com/html/app/code/core/Mage/Core/functions.php(73): mageCoreErrorHandler(2, 'include(Mage/Ad...', '/home/24836/dom...', 73, Array)
#1 /home/24836/domains/28spin.com/html/app/code/core/Mage/Core/functions.php(73): __autoload()
#2 /home/24836/domains/28spin.com/html/app/code/core/Mage/Core/Model/Config.php(788): __autoload('Mage_Adminhtml_...')
#3 /home/24836/domains/28spin.com/html/app/Mage.php(317): Mage_Core_Model_Config->getModelInstance('Mage_Adminhtml_...')
#4 /home/24836/domains/28spin.com/html/app/Mage.php(331): Mage::getModel('adminhtml/syste...', Array)
#5 /home/24836/domains/28spin.com/html/app/code/core/Mage/Adminhtml/Block/System/Config/Form.php(261): Mage::getSingleton('adminhtml/syste...', Array)
#6 /home/24836/domains/28spin.com/html/app/code/core/Mage/Adminhtml/Block/System/Config/Form.php(174): Mage_Adminhtml_Block_System_Config_Form->initFields('adminhtml/syste...')
#7 /home/24836/domains/28spin.com/html/app/code/core/Mage/Adminhtml/Block/System/Config/Edit.php(85): Mage_Adminhtml_Block_System_Config_Form->initForm(Object(Varien_Data_Form_Element_Fieldset), Object(Mage_Core_Model_Config_Element), Object(Mage_Core_Model_Config_Element))
#8 /home/24836/domains/28spin.com/html/app/code/core/Mage/Adminhtml/controllers/System/ConfigController.php(82): Mage_Adminhtml_Block_System_Config_Edit->initForm()
#9 /home/24836/domains/28spin.com/html/app/code/core/Mage/Core/Controller/Varien/Action.php(367): Mage_Adminhtml_System_ConfigController->editAction()
#10 /home/24836/domains/28spin.com/html/app/code/core/Mage/Core/Controller/Varien/Router/Admin.php(143): Mage_Core_Controller_Varien_Action->dispatch()
#11 /home/24836/domains/28spin.com/html/app/code/core/Mage/Core/Controller/Varien/Front.php(158): Mage_Core_Controller_Varien_Router_Admin->match('edit')
#12 /home/24836/domains/28spin.com/html/app/Mage.php(457): Mage_Core_Controller_Varien_Front->dispatch(Object(Mage_Core_Controller_Request_Http))
#13 /home/24836/domains/28spin.com/html/index.php(46): Mage::run()
#14 {main}
 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

Looks like your upgrade did not complete successfully. Did you see any errors in the output frame during upgrade? Try to re-install Mage_All_Latest, preferably from the command line via SSH:

./pear install -f magento-core/Mage_All_Latest

It should install/upgrade the missing packages.

 
Magento Community Magento Community
Magento Community
Magento Community
 
B00MER
Sr. Member
 
Avatar
Total Posts:  130
Joined:  2007-12-27
DFW, TX
 

Had the same issue from 1.8.1 to 1.2.1, I simply downloaded the full release and added the file manually.  Seems to have fixed the issue.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top