Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

500 Internal Server Error - Basic Magento Install
 
ckauto
Jr. Member
 
Total Posts:  6
Joined:  2013-02-09
 

I had Magento installed once, and was working through the installer, then I did one step to change the file permissions and now I get 500 internal server error.  It’s been about two days, I deleted and did fresh re-install again, and changed permissions a bunch of times. This is taking forever each time uploading and changing permissions.  I have installed Magento before for another website about 3 years ago, but it has been a while.

I changed the permissions following the instructions step 4 here.
http://www.magentocommerce.com/wiki/1_-_installation_and_configuration/magento_installation_guide
Also same as on step 6 here.
http://www.magentocommerce.com/knowledge-base/entry/magento-installation-guide

I change permissions to 777 across the board, files and folders.
Even a simple http://www.mywebsite.com/images - Does not work!!

But reading each tutorial it says I have to change permissions so I did that before I completed the installation wizzard so there would not be any installation problems with the installer reading/writing.  Each time I change permissions to all files & folders it takes more than a couple hours.  And each time I delete and re-upload all files to the FTP again it takes an hour or two.  I have already invested a couple days into this and still have nothing.  :( Seriously willing to pay someone to do this because this is getting ridiculous.

Now I am on Step6 here -
http://www.magentocommerce.com/knowledge-base/entry/magento-installation-guide

Even with permissions set to 777 I can not get to http://www.example.com/magento/, or http://www.example.com/magento/install/.
I just always get Internal Server Error.

Even if I do it without changing the permissions it doesn’t work.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ckauto
Jr. Member
 
Total Posts:  6
Joined:  2013-02-09
 

To verify magento is compatible here is my System Information (lunapages)
Operating System CentOS release 5.5 (Final)
Kernel Version 2.6.18-194.17.4.el5PAE
Apache Version 2.2.3
MySQL Version 5.0.77
PERL Path /usr/bin/perl
PERL Version 5.8.8
PHP Path /usr/bin/php
PHP Version 5.3.14
PHP53 Path /opt/php53/bin/php
PHP53 Version 5.3.14
Ruby Path /usr/local/bin/ruby
Ruby Version 1.8.7

I created ANOTHER magento directory, this one is magento3.
Still trying to get this worked out, went through the basic instlalation walk through at least 20 times already - Still no solution.

 
Magento Community Magento Community
Magento Community
Magento Community
 
omnisity
Jr. Member
 
Total Posts:  1
Joined:  2013-02-18
 

Not sure but you could try deleting the .htaccess file.

I’ve then been able to install magento on a Fasthosts Shared server with a Shared MySQL database.

I initially experienced the same issue, being new to php and the magento, have to say wasn’t the best of starts but with a little trial and error i’ve been able to get things sort of working. I’m pretty much a newbie on PHP so please don’t mistake me for an expert.

I found i couldn’t run anything until i deleted the .htaccess file. Since removing that file i could run the magento-check.php file which states apart from MySQL not being installed on the server, everything else is ready to go.

I ran the installer and the home page loads but none of the links work. I just get 404 errors.

I tried to re-upload the .htaccess file, but then get an internal server error. Through a process of elimination and this forum, i’ve found if you comment out lines 116 & 117

## enable rewrites

# Options +FollowSymLinks
# RewriteEngine on

And go into Admin Panel > System > Configuration > Search Engines Optimization > Use Web Server Rewrites > NO

This gets the site working but you have links like:

mydomain.com/index.php/apparel/shoes/womens/anashria-womens-premier-leather-sandal.html

instead of

mydomain.com/apparel/shoes/womens/anashria-womens-premier-leather-sandal.html

This image content is still not displayed on the internal pages and i don’t like the fact index.php is in the URL so i’ll continue to try and find a solution. If anyone out there can help, i’d appreciate it! smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
GoMageTeam
Guru
 
Avatar
Total Posts:  356
Joined:  2013-01-13
Warsaw, Poland
 

Hello,

You can set right file permissions using SSH by running the following command

find . -type d -exec chmod 755 {} \\;
    
find . -type f -exec chmod 644 {} \\;
Then you should replace your .htaccess file to the standard one.
The most widespread reason of 500 error (Internal Server Error) is the incorrect syntax of .htaccess file or the unsupported directives in it. The solution is more often to comment out the Options directive (you should write the grate -# at the beginning of the line) and it will solve the problem.
Then you can get more information about your problem and how to solve it here:
http://www.techjam.gr/2012/magento/solve-magento-500-internal-server-errors/
 
Magento Community Magento Community
Magento Community
Magento Community
 
imedzgurl
Jr. Member
 
Total Posts:  2
Joined:  2011-02-25
 

SOLVED my 500 error

http://www.learnmagento.org/magento-bug-fixes/solve-500-internal-server-error-on-magento-installation/#comments

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top