Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

USPS Standard Post
 
recycling_rules
Jr. Member
 
Total Posts:  10
Joined:  2012-07-10
 

Ever since January 27, 2013, my USPS Parcel Post isn’t working.  I understand that the Post Office rolled out new pricing on that day and renamed “Parcel Post” to “Standard Post”, however my Magento installation still shows “Parcel Post”.  I am using Magento Community Edition V1.7.0.2.  How do I get the Allowed Methods listing to include “Standard Post”?

Image Attachments
Capture Magento Shipping Methods USPS Parcel Post.JPG
 
Magento Community Magento Community
Magento Community
Magento Community
 
nohart
Member
 
Total Posts:  62
Joined:  2012-10-09
California
 

I am interested in the new USPS shipping rates. I cant believe the lack of support this store gets. This should have been ready to roll out as soon as it was implemented. And we should not have to come up with code on our own it should be officially provided to us from Magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bsingley
Jr. Member
 
Total Posts:  3
Joined:  2012-07-12
 

I’m having the same issue...would love to figure it out. Anybody got any ideas for getting “standard Post” to show up as a shipping option?

 
Magento Community Magento Community
Magento Community
Magento Community
 
nohart
Member
 
Total Posts:  62
Joined:  2012-10-09
California
 

I fixed fixed my store by doing this:

Go to In file: /app/code/core/Mage/Usa/etc/config.xml

Find the First-Class Mail International Parcel and replace it with “First-Class Package International Service” (without quotes)

also find “Parcel Post” and replace it with “Standard Post” (without quotes)

You need to replace this 2 places each in the config.xml

Save it & Clear cache,

Make sure you select the new class in Config > Shipping Methods > USPS after you clear the cache. You have to select this new class.

Now go and check that the shipping option is showing in the checkout page.

 
Magento Community Magento Community
Magento Community
Magento Community
 
recycling_rules
Jr. Member
 
Total Posts:  10
Joined:  2012-07-10
 

Thanks.  That worked!  I’m back up and running! 

Most of my customers choose FedEx Ground, but for those customers in remote areas of the country where FedEx charges their Extended Service Delivery charge (usually +$3.50), Standard Post is the lower cost shipping method.  And for my occasional customer in Hawaii and Alaska, Standard Post is really the only option!

Thanks again!  grin

http://www.recyclingrules.org

 
Magento Community Magento Community
Magento Community
Magento Community
 
N Lopez
Sr. Member
 
Total Posts:  94
Joined:  2008-06-16
 

I am having a odd problem with the Standard Post shipping method: It does not work for addresses close to the origin address (same state or neighboring state) but it works just fine if I ship from coast to coast.
i wonder if someone else is having the same problem or have an idea what is going on?

 
Magento Community Magento Community
Magento Community
Magento Community
 
8asic
Jr. Member
 
Total Posts:  7
Joined:  2009-08-27
 

I believe the behavior you’re seeing is by design.  Those close to you will receive the item in the same timeframe as a priority shipment, so they hide the standard post option and reduce the price of the priority shipment to the same rate as a standard shipment would be.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top