Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Upgrading from 1.4.0.2 to 1.7
 
mperez
Jr. Member
 
Total Posts:  11
Joined:  2011-01-04
 

Hi all,

i’am trying to upgrade ma store for long time.

I’m upgrading from 1.4 to 1.7. I am traing to install 1.7 over a copy of 1.4 data base and after a long, long time instalation i receive the next report error:
______________________________________________________________________________________________________

a:5:{i:0;s:226:"Error in file: “E:\xampp\htdocs\fol17\app\code\core\Mage\Customer\sql\customer_setup\mysql4-upgrade-1.5.9.9-1.6.0.0.php” - SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry ‘0-238’ for key ‘UNQ_BY_CUSTOMER‘“;i:1;s:956:"
#0 E:\xampp\htdocs\fol17\app\code\core\Mage\Core\Model\Resource\Setup.php(645): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 E:\xampp\htdocs\fol17\app\code\core\Mage\Core\Model\Resource\Setup.php(437): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’upgrade’, ‘1.4.0.0.13’, ‘1.6.2.0.1’)
#2 E:\xampp\htdocs\fol17\app\code\core\Mage\Core\Model\Resource\Setup.php(320): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(’1.4.0.0.13’, ‘1.6.2.0.1’)
#3 E:\xampp\htdocs\fol17\app\code\core\Mage\Core\Model\Resource\Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 E:\xampp\htdocs\fol17\app\code\core\Mage\Core\Model\App.php(417): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 E:\xampp\htdocs\fol17\app\code\core\Mage\Core\Model\App.php(343): Mage_Core_Model_App->_initModules()
#6 E:\xampp\htdocs\fol17\app\Mage.php(683): Mage_Core_Model_App->run(Array)
#7 E:\xampp\htdocs\fol17\index.php(87): Mage::run(’’, ‘store’)
#8 {main}”;s:3:"url”;s:42:"/fol17/index.php/install/wizard/installDb/”;s:11:"script_name”;s:16:"/fol17/index.php”;s:4:"skin”;s:7:"default";}

___________________________________________________________________________________________________

Any idea about what’s happening?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

I would turn off integrity constraints before you run you database upgrade.

From MySQL

SET foreign_key_checks 0;

Run upgrade (New backed up db)

SET foreign_key_checks 1;
 
Magento Community Magento Community
Magento Community
Magento Community
 
williambest
Jr. Member
 
Total Posts:  5
Joined:  2012-06-07
 

You can try upgrading Magento another way. Install fresh Magento 1.7. and migrate your database straight from your old version to a new one without errors. make the backup of current database (just in case) and follow the instructions. If you do everything correctly you will get a new updated store with no headaches.
Good Luck

 
Magento Community Magento Community
Magento Community
Magento Community
 
magebay
Sr. Member
 
Avatar
Total Posts:  122
Joined:  2012-10-09
Thai Nguyen
 
Brent W Peterson - 16 February 2013 06:09 AM

I would turn off integrity constraints before you run you database upgrade.

From MySQL

SET foreign_key_checks 0;

Run upgrade (New backed up db)

SET foreign_key_checks 1;

Working with me. Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
sujoko
Jr. Member
 
Total Posts:  1
Joined:  2010-11-14
 
Brent W Peterson - 16 February 2013 06:09 AM

I would turn off integrity constraints before you run you database upgrade.

From MySQL

SET foreign_key_checks 0;

Run upgrade (New backed up db)

SET foreign_key_checks 1;

where i can find the foreign_key_checks mr. ?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top