Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

How to remove /default from base url after calling getUrl(’’) method into the template
 
tiarly
Jr. Member
 
Total Posts:  1
Joined:  2013-01-19
 

Guys, im really having some doubts about how i can remove the /default part from my base url…

In the the admin my base url is alreay correct with my domain e.g: http://www.mystore.com

But whenever i call the getUrl(’’) method it seems that somehow is appending this /default part and i dont know where and how i can remove that.

Basically, i have this:
In my home page, i have my logo with de url set to: http://www.mystore/default/ by getUrl() method.

I’ve already checked my .htacess, there is nothing that coud be resulting that, only the normal .htacces settings from magento it self.

Is there anyone who can help me with that?

Suggestions are very welcome!

 
Magento Community Magento Community
Magento Community
Magento Community
 
mpescador
Jr. Member
 
Total Posts:  3
Joined:  2012-07-04
 

Configuration->Web->URL Options-> Change to NO Add store code to URL.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top