Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

[SOLVED] Payment Method Configuration page blanks out with 500 error
 
PolrBear
Jr. Member
 
Total Posts:  25
Joined:  2012-01-30
 

My Magento 1.7.0.2 installation is running fine except for this one thing.  I can get to anything in the configuration area (anything I’ve tried, that is) except the payment method screen.  When I try to access that, it returns a blank white screen and the dreaded 500 internal server error.  I have checked the Apache error log, and here is the only thing I find from that pageload:

[Tue Feb 12 17:51:51 2013] [error] [client 204.197.xxx.xxx] client denied by server configuration: /home/username/public_html/dev/app/etc/local.xml

The above error actually logs whenever I access any configuration screen, not just that one.

I enabled Magento logging in the configuration, but no log files have been create at /var/log.

Any ideas would be greatly appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

try to disable custom payment methods
and keep checking error logs it must be there, error you get.

enable error output on screen.

 
Magento Community Magento Community
Magento Community
Magento Community
 
PolrBear
Jr. Member
 
Total Posts:  25
Joined:  2012-01-30
 

Thanks for the reply!

MagenX - 12 February 2013 03:02 PM

try to disable custom payment methods

I haven’t installed any custom payment methods, and how can I manage them when the payment methods config page is the one that won’t come up?

and keep checking error logs it must be there, error you get.

Apache shows nothing and there is no Magento error log. What else can I check?

enable error output on screen.

How do I do that?

 
Magento Community Magento Community
Magento Community
Magento Community
 
PolrBear
Jr. Member
 
Total Posts:  25
Joined:  2012-01-30
 

I got it sorted out by adding the old

ini_set('display_errors','on');
to the top of index.php.  It was a max memory size error, which I resolved by increasing the limit.  Magento is a hungry beast…
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top