Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Invalid block type
 
smallory
Jr. Member
 
Total Posts:  4
Joined:  2013-02-05
 

Sorry if this has been to discussed to death, but for two days I cannot find an answer to this issue.
We need to extend a few classes and add a couple of our own, yet when ever we try to add a block, we get the \\\"Invalid block type\\\” error message.

snippet form app/code/local/Tantor/Custom/etc/config.xml....

<global>
<blocks>

<custom>
<class>Tantor_Custom_Block</class>
</custom>

<test>
<class>Tantor_Test_Block</class>
</test>

<catalog>
<rewrite>
<navigation>Tantor_Custom_Block_Navigation</navigation>
</rewrite>
</catalog>
</blocks>
<global>

I have followed many of the tutorials from simple \\\’hello worlds\\\’ to navigation changes ... exactly the same error.
Everything else appears to me working, the modules show under Advanced ... I turned off the cache ... I\\\’m stuck.

Any suggestions would be appreciated

mag 1.7.0.2 CE

Scott

 
Magento Community Magento Community
Magento Community
Magento Community
 
smallory
Jr. Member
 
Total Posts:  4
Joined:  2013-02-05
 

If anyone was paying attention ... I learned that you must disable Compilation.

System > Tools > Compilation

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top