Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Undefined inde in der system.log
 
icedoutbiz
Jr. Member
 
Total Posts:  11
Joined:  2011-02-01
 

Hallo,

habe ich der System.log alle paar Sekunden diese Fehler:

2013-01-28T16:55:01+00:00 ERR (3): Notice: Undefined index:  httponly in /icehatpg/www.iced-out-shop.com/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 94

2013-01-28T16:55:01+00:00 ERR (3): Notice: Undefined index:  secure in /icehatpg/www.iced-out-shop.com/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 96

2013-01-28T16:55:01+00:00 ERR (3): Notice: Undefined index:  domain in /icehatpg/www.iced-out-shop.com/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 98

Kennt jemand das Problem? Und die Lösung?

Gruß

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siggi_Schmitz
Enthusiast
 
Avatar
Total Posts:  811
Joined:  2011-07-03
 

Das scheint ein cookie - Problem zu sein, lösch mal deine Browercookies und probier`s nochmal...wenn nicht, gibt es denn irgendwelche Fehler im Shop, also funzt sonst alles? Produkte in den Warenkorb legen, bestellen, etc.?

 
Magento Community Magento Community
Magento Community
Magento Community
 
icedoutbiz
Jr. Member
 
Total Posts:  11
Joined:  2011-02-01
 

Ja, es liegt an der Varien.php

In der 1.7.0.2 muss da irgendwas angepasst werden, damit die Cookies und Sessions wieder normal laufen.

Sonst funktioniert alles.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siggi_Schmitz
Enthusiast
 
Avatar
Total Posts:  811
Joined:  2011-07-03
 

Hab schon diverse Shop mit 1.7.0.2 erstellt und hab diesen Fehler noch nie gesehen…

Wenn du nur die Fehlermeldung weghaben willst, dann öffne die Datei, geh zur Zeile 94 und ändere den Codeblock der dort anfängt von

if (!$cookieParams['httponly']{
            
unset($cookieParams['httponly']);
            if (!
$cookieParams['secure']{
                
unset($cookieParams['secure']);
                if (!
$cookieParams['domain']{
                    
unset($cookieParams['domain']);
                
}
            }
        }

zu

if (!isset($cookieParams['httponly'])) {
            
unset($cookieParams['httponly']);
            if (!isset(
$cookieParams['secure'])) {
                
unset($cookieParams['secure']);
                if (!isset(
$cookieParams['domain'])) {
                    
unset($cookieParams['domain']);
                
}
            }
        }

Damit sollte die Fehlermeldung weg sein.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top