Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

What version of Magento should I use when I have old = PHP 5.2.9 on my server
 
maver2
Jr. Member
 
Total Posts:  1
Joined:  2013-01-25
 

I would endlessly appreciate the answer from the subject, this old version od php I have on my server with many other customers ...

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
SimpleHelixcom
Enthusiast
 
Avatar
Total Posts:  906
Joined:  2007-08-31
Huntsville, AL
 

Magento is officially compatible with PHP versions 5.2.13 - 5.3.15. You should be advised that there is a bug in PHP 5.2.9 that, in some cases, will cause Magento’s get/set magic methods not to create underscores properly. This can result in direct item links being broken.

 
Magento Community Magento Community
Magento Community
Magento Community
 
GoMageTeam
Guru
 
Avatar
Total Posts:  356
Joined:  2013-01-13
Warsaw, Poland
 

Hello,

Please, look at the requirements:
http://www.magentocommerce.com/wiki/1_-_installation_and_configuration/magento_installation_guide

There should be the minimal version PHP 5.2.13 or newer, so you see that there will be a lot of bugs on your Magento version.
We recommend you the last PHP version. You have the server and there is PHP version 5.2.9, so Magento doesn’t work on it.
If you want it works, you need to update PHP version.
If it is not your server, you need to contact your host provider or run PHP like cgi application.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top