Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Email e SMTP in magento
 
maxistile
Jr. Member
 
Total Posts:  2
Joined:  2009-01-30
 

Ciao a tutti, sono nuovo ed ho installato proprio in quesit giorni magento....(dopo 15 tentativi c’è l’ho fatta!), ora stavo iniziando a dare uno sguardo ma ecco il primo problema:

1 dove devo andare e cosa devo fare per impostare magento per ricevee ed inviare email?
ho profato dal front end a registrare un nuovo utente,a inviare email con il tasto ‘’contattaci’’,ma purtroppo non ricevo nessuna email e mi appare la scritta:

‘’Impossibile inoltrare la richiesta. Per favore, riprova più tardi’’

utilizzo magento 1.2.0.1 e sono su hosting free ilbello.com

Attendo il vostro aiuto....è la prima volta che mi addentro in un CMS

 
Magento Community Magento Community
Magento Community
Magento Community
 
yugyn_lonewolf
Sr. Member
 
Total Posts:  108
Joined:  2008-05-31
 

Ciao max,

ho lo stesso problema e sono in locale, sotto wamp server su Win Vista!
Sto cercando di capire anche io come settare le mail; chi lo capisce prima lo posta qui? smile

A presto.

P.S. come va l’hosting “ilbello”?

 
Magento Community Magento Community
Magento Community
Magento Community
 
patrecord
Guru
 
Avatar
Total Posts:  461
Joined:  2008-06-01
 

in admin/sistema/configurazioni/pannello generale (a destra)/indirizzi mail del negozio. Da qui puoi settare i tuoi indirizzi e-mail.

Per chi è in locale le mail con molta probabilità non arrivano perchè in locale NON è installato un mailserver;)

 
Magento Community Magento Community
Magento Community
Magento Community
 
yugyn_lonewolf
Sr. Member
 
Total Posts:  108
Joined:  2008-05-31
 

Ciao,

ho provato Magento su ilbello…
Devo dire che gira niente male!!!
Molto più veloce del mio in locale su wamp server.

Per la storia delle mail, gli indirizzi del negozio li ho già settati.
Dici che manca il mailserver?
Io pensavo che fosse possibile utilizzare la mail tramite una configurazione POP e SMTP…

A presto.

 
Magento Community Magento Community
Magento Community
Magento Community
 
maxistile
Jr. Member
 
Total Posts:  2
Joined:  2009-01-30
 
yugyn_lonewolf - 01 February 2009 02:21 PM

Ciao,

ho provato Magento su ilbello…
Devo dire che gira niente male!!!
Molto più veloce del mio in locale su wamp server.

Per la storia delle mail, gli indirizzi del negozio li ho già settati.
Dici che manca il mailserver?
Io pensavo che fosse possibile utilizzare la mail tramite una configurazione POP e SMTP…

A presto.

ciao YUNGYN si su ilbello.com gira bene Magento....mi puoi spiegare come hai fatot ad impostare le email???
io ho provaot a mettere una mia email sulla quale voleov ricevere gli ordini o le richieste effettuate trmite lo store magento,ma facendo delle prove ho notato che non ricevo niente sull’email impostata...anche io pensavo di impostare SMTP,ma non trovo dove....sinceramente lo trovo bello magento..ma un po difficile da utilizzare e dimpostare...ho provaot ieri cubecart e non ho trovaot tutte le difficolta ke trovo con magento...comunque attendo il tuo aiuto pe rle email...grazie

 
Magento Community Magento Community
Magento Community
Magento Community
 
yugyn_lonewolf
Sr. Member
 
Total Posts:  108
Joined:  2008-05-31
 

Mi dispiace max, ma ancora non ci soho riuscito! Nè in locale, nè su ibello.
Appena ci riesco non dubitare che posto qui la soluzione.

Effettivamente Magento è abbastanza tosto da configurare, almeno per noi che siamo alla nostra “prima volta”.
Ovvio che dopo capito i trucchetti tutto è in discesa…

Infatti a me mancano un paio di cosette per terminare il “giro completo” per poter partire con un e-commerce:
- la storia delle mail
- l’impostazione dell’IVA al 20% (che a me non ne vuole sapere di andare)
- un funzionamento strano con gli store multilingua

più altre cosette tipo:
- moduli di pagamento da me creati non vengono tradotti
- moduli di pagamento scaricati che a me funzionano in modo sbagliato

Amico mio, come tutte le cose, Magento è tosto come inizio.
E più è flessibile ed espandibile il prodotto, più è difficile configurarlo…

Ci sentiamo appena ci sono novità…

 
Magento Community Magento Community
Magento Community
Magento Community
 
patrecord
Guru
 
Avatar
Total Posts:  461
Joined:  2008-06-01
 

provate con questa extension;)

http://www.magentocommerce.com/extension/460/advanced-smtp--artson.it

Per quanto riguarda le tasse prova a leggere la guida disponibile qui sul sito....la configurazione in effetti non è delle più facili e ci vuole mooooooooolta pazienza;)

 
Magento Community Magento Community
Magento Community
Magento Community
 
yugyn_lonewolf
Sr. Member
 
Total Posts:  108
Joined:  2008-05-31
 

Ciao pat, grazie del suggerimento.

Dunque…
Ho provato ad installare il pacchetto e l’ho pure configurato, ma niente da fare!
Ho provato ad utilizzare gmail; ho provato sia con SSL che con TSL, con la porta 465 e 587.
Ho rimosso le cartelle della cache ad ogni tentativo.
Ho provato:
- ad inviare newsletter, ma rimangono sempre in stato “invio in corso”
- a richiedere l’attivazione account tramite mail, ma non ricevo niente
- a utilizzare la form “Contattaci”, ma mi esce sempre il messaggio “il servizio non è al momento disponibile”

Niente di niente…
Sono in locale, sotto wamp server su Win Vista ed ho Magento 1.2.0.3

 
Magento Community Magento Community
Magento Community
Magento Community
 
yugyn_lonewolf
Sr. Member
 
Total Posts:  108
Joined:  2008-05-31
 

Buone nuove max!!!

Sono riuscito a far funzionare il discorso mail da locale!
Dunque…

Devi andare in Amministrazione->Sistema->Configurazione

- Generale->Indirizzi e-mail del negozio
Imposta tutti gli indirizzi del tuo negozio ma al posto del nome mittente metti lo stesso indirizzo.
Es per contatti generali:
mome mittente: miamail@mail.it
email mittente: miamail@mail.it

Il problema, almeno per me stava proprio qua!
Io avevo “Owner” nel campo nome mittente; dopo ore di sbattimenti sul codice ho visto che nel campo “From” della composizione della mail arriva proprio “Owner”, quando iinvece deve arrivarci “miamail@mail.it”.
Ripeto, non so se sia un mio problema o no, ma fai così per il momento; purtroppo il codice andava avanti, senza generare un errore visibile all’utente e dava l’impressione dell’invio della mail quando invece non veniva inviato niente di niente.

- Generale->Contatti
Abilitalo, indica la mail a cui spedire il messaggio e specifica il contatto da usare; ultimo lascia il template di default.

- Clienti->Configurazione Cliente->Opzioni creazioni nuovo account
- gruppo default: General
- dominio: a piacere tuo
- default welcome: template di default
- mittente mail: a piacere tuo
- mail richiesta di conferma: si
- conferma link mail: template di default
- welcome mail: template di default

- Avanzato->Sistema->Opzioni SMTP
- disabilita: no
- host: il tuo host smtp
- porta: 25

Per quanto riguarda il tuo host, devi digitare l’host smtp del provider che ti fornisce internet.
Io, avendo Fastweb, ho:  smtp.fastwebnet.it

Con questa configurazione puoi vedere un giro completo di creazione account.
Lato cliente riceverai la mail di conferma registrazione e successivamente la mail di benvenuto.

Funziona anche il “contattaci”; vedrai appunto il messaggio digitato lato cliente nella mail che riceverai.

Mi manca solo vedere il discorso newsletters

Funziona anche il discorso mail (almeno credo) per la creazione degli ordini.
Non ho potuto verificare al 100% perchè nel confermare un ordine mi esce un alert con il testo “undefined”; gli ho dato “OK”, ho rifatto “Place order” ed è ricomparso l’errore, ho fatto così per 4-5 volte e mi sono ritrovato le mail dell’ordine evaso e 4-5 ordini fatti nel “myOrders”!!!
Probabile però che sia colpa di qualche cosa che ho cambiato nel codice.
Infatti ho fatto un paio di cambi e ripristini per capire l’intoppo della mail.

Questo discorso ovviamente funziona solo in locale; su ilbello non va.
Questo perchè bisogna specificare l’host SMTP che usa ilbello (ammesso che lo abbia nello spazio free che usiamo) per inviare le mail.

Lo stesso risultato è ottenibile anche cambiando il file lib\Zend\Mail\Transport\SendMail.php, nella funzione “_sendMail”

da:

public function _sendMail()    
    
{
        
if ($this->parameters === null{
            $result 
mail(
                
$this->recipients,
                
$this->_mail->getSubject(),
                
$this->body,
                
$this->header);
.....
.....

a

public function _sendMail()    
    
{
        
if ($this->parameters === null{
   
            ini_set
("SMTP","smtp.fastwebnet.it"); 
            
ini_set("smtp_port","25"); 

            
$result mail(
                
$this->recipients,
                
$this->_mail->getSubject(),
                
$this->body,
                
$this->header);
.....
.....

Non so se è possibile in questo punto inserire altri parametri SMTP; se fosse cpossibile, si potrebbero inserire le credenziali di accesso ad una propria mail e le altre proprietà per girare tramite un SMTP tipo gmail.
Si otterrebbe lo stesso risultato del pacchetto suggerito da patrecord (che a me non funzionava ieri; chissà adesso con gli indirizzi modificati...)

Per ora è tutto… a presto ragazzi.

 
Magento Community Magento Community
Magento Community
Magento Community
 
patrecord
Guru
 
Avatar
Total Posts:  461
Joined:  2008-06-01
 

Ripeto che chi è in locale (macchine windows) e non ha un mailserver sempre installato in locale è normale che le mail non funzionino. Altro discorso se si riesce ad usare un altro mailserver tipo quello di fastweb citato o qualsiasi altro.

A me non risulta tutto sto casino per far funzionare le mail...cioè sono andate sempre al primo colpo in locale su Mac. In produzione invece ho avuto problemi risolti proprio con la extension che vi ho linkato.

Per finire provate a risolvere in qualsiasi altro modo tranne che con la modifica al file che hai citato (lib\Zend\Mail\Transport\SendMail.php) in quanto al primo aggiornamento ti si “brucia” la modifica e la devi rifare.

Bye

 
Magento Community Magento Community
Magento Community
Magento Community
 
yugyn_lonewolf
Sr. Member
 
Total Posts:  108
Joined:  2008-05-31
 

Concordo patrecord, è un file la cui modifica deve essere evitata.
Quello che ho postato era solo per risolvere in qualche modo il test delle mail a chi è su Win e non ha un mail server affiancato.

Immagino che Mac, come Linux, abbia di default qualche mail server, per questo a te fila tutto liscio…

Toglimi solo una curiosità.
Il casino della storia dei contatti che ho avuto, ti è capitato?
O a te è filato tutto liscio mettendo solo la mail mittente e rimanendo il nome del mittente così come dovrebbe essere?

 
Magento Community Magento Community
Magento Community
Magento Community
 
patrecord
Guru
 
Avatar
Total Posts:  461
Joined:  2008-06-01
 

Dire che mi è filato tutto liscio sarebbe un eufemismo:) ....considera che ci sto lavorando sopra da settembre e dovrei aprire a giorni. Con le mail ho avuto un problema sul sito di produzione legato all’dentificazione via ssl con il server SMTP (spero di aver scritto bene) e appunto avevo risolto. In pratica ad ogni tentativo di invio mail mi si verificava un internal server error.

Per la storia dei contatti ho riletto al volo e non ho ben capito....ti riferisci al fatto che se usi la pagina dei contatti non ti funziona? In effetti il messaggio è un pò ambiguo perchè non si capisce se il servizio “Contattaci” non è attivo oppure se sono le “mail” a non essere “attive”.

Comunque in admin il servizio contattaci si attiva/disattiva....tu come lo hai impostato adesso?

 
Magento Community Magento Community
Magento Community
Magento Community
 
yugyn_lonewolf
Sr. Member
 
Total Posts:  108
Joined:  2008-05-31
 

No, mi riferisco agli “indirizzi mail del negozio”.

Per ogni indirizzo c’è il campo “nome mittente” ed “indirizzo mail”.
Quando scarichi Magento sono già stabiliti con indirizzi di fantasia.

Io avevo cambiato l’indirizzo di ogni contatto indicato in questa sezione, lasciando inalterato il nome.
Nel seguire il funzionamento del codice, ho visto che le mail non partivano per via del fatto che invece dell’indirizzo, nel campo “from” della composizione mail ci andava il nome del contatto, nel mio caso “Owner”, il primo della sezione.
Nessun errore a video, ma nessuna mail partiva!

Difatti la configurazione SMTP l’avevo già impostata.
Appena ho cambiato il nome di ogni contatto con l’indirizzo mail (nel mio caso “Owner” con “mioindirizzo@mail.it) ha funzionato tutto.

Era questa la manovra che ti chiedevo se l’avevi fatta o no, visto che hai detto che su Mac ha funzionato tutto a primo colpo…

 
Magento Community Magento Community
Magento Community
Magento Community
 
patrecord
Guru
 
Avatar
Total Posts:  461
Joined:  2008-06-01
 

no...io i nomi non li ho toccati...ho messo su tutti Servizio Clienti e sotto l’indirizzo mail.

 
Magento Community Magento Community
Magento Community
Magento Community
 
yugyn_lonewolf
Sr. Member
 
Total Posts:  108
Joined:  2008-05-31
 

Boh, non so che dirti…

A parte questo sto provando a far funzionare l’"Advanced SMTP settings”.
Ma non ne vuole sapere, nè in locale nè su “ilbello”.

Eppure credo di averlo configurato bene:

- enabled advanced settings: yes
- auth mode: login
- username: indirizzodipostagmail@gmail.com (ho provato anche senza il “@gmail.com")
- password: miapassword
- smtphost: smtp.gmail.com
- smtp port: 465 (ho provato anche con 587)
- use SSL: Yes (TSL) - ho provato anche con NO e Yes (SSL)

Nada de nada…

 
Magento Community Magento Community
Magento Community
Magento Community
 
equilibrio
Member
 
Avatar
Total Posts:  39
Joined:  2009-03-02
 

su ilbello.com è logico che non funzionano le e.mail.

leggi qui: http://forum.ilbello.com/supporto-hosting/php-mail()/

devi fare la richiesta per farti attivare la funzione php-mail()

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2