Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Soap Api - can’t login
 
barannd
Jr. Member
 
Total Posts:  4
Joined:  2013-01-22
 

Hey,

if I Want to login via the api, I get the following error message. To test it I use a software called “soapUI”.

<faultcode>WSDL</faultcode>
<
faultstring>SOAP-ERRORParsing WSDLCouldn't load from 'http://mydomain.com/index.php/api/v2_soap/index/?SID=0qn2cd6u9d3gcucpidi2903vor4t4obc&amp;wsdl=1' : Start tag expected, '<' not found</faultstring>

I can connect to the wsdl file, but if i try the login function, the message appears in the response. Also I can view the wsdl file in the browser in api v1 and v2.

Magento version: 1.7.0.2
Soap Api version: v1 and v2 (same problem)
Wsdl path tov1: http://mydomain.com/api/soap/?wsdl
Wsdl path to v2: http://mydomain.com/api/v2_soap?wsdl=1

Thanks for any help

 
Magento Community Magento Community
Magento Community
Magento Community
 
TreInnova
Guru
 
Avatar
Total Posts:  465
Joined:  2009-02-20
Fano
 

Hi,
By this phrase of the error “Start tag expected, ‘<’ not found”, the basic problem must be the missing of the XML Start tag in probably the Magento file “wsdl.xml”.

I practically don’t know the easiest solution, but you can definitely go through each line manually after you have loaded the WSDL in your browser successfully. Based on the line of the error, you will have to identify the Magento module, and then rectify this defect.

Hope it helps.

source : SOAP-ERROR: Parsing WSDL: Couldn’t load from

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top