Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Sitemap.xml issue
 
denialdesign
Jr. Member
 
Total Posts:  9
Joined:  2012-02-12
 

I’ve generated a sitemap.xml file in Magento CE admin (Catalog > Google Sitemap) but the xml is all messed up for the products and categories. The CMS pages xml is fine. Here’s what I mean

<?xml version="1.0" encoding="UTF-8"?>
<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">http://www.mydomain.co.uk/cutting-and-embossing.html2012-08-10daily0.5http://www.mydomain.co.uk/cutting-and-embossing/marianne-craftables.html2012-08-03daily0.5http://www.mydomain.co.uk/cutting-and-embossing/yvonne-creations.html2012-09-16daily0.5http://www.mydomain.co.uk/cutting-and-embossing/docrafts.html2012-11-20daily0.5http://www.mydomain.co.uk/cutting-and-embossing/nellie-snellen-embossing-folders.html2012-10-01daily0.5<url><loc>http://www.mydomain.co.uk/</loc><lastmod>2013-01-21</lastmod><changefreq>daily</changefreq><priority>0.2</priority></url><url><loc>http://www.mydomain.co.uk/enable-cookies</loc><lastmod>2013-01-21</lastmod><changefreq>daily</changefreq><priority>0.2</priority></url><url><loc>http://www.mydomain.co.uk/privacy-policy-cookie-restriction-mode</loc><lastmod>2013-01-21</lastmod><changefreq>daily</changefreq><priority>0.2</priority></url><url><loc>http://www.mydomain.co.uk/about-us</loc><lastmod>2013-01-21</lastmod><changefreq>daily</changefreq><priority>0.2</priority></url><url><loc>http://www.mydomain.co.uk/customer-service</loc><lastmod>2013-01-21</lastmod><changefreq>daily</changefreq><priority>0.2</priority></url><url><loc>http://www.mydomain.co.uk/conditions-of-sale</loc><lastmod>2013-01-21</lastmod><changefreq>daily</changefreq><priority>0.2</priority></url><url><loc>http://www.mydomain.co.uk/dolls-house-miniatures</loc><lastmod>2013-01-21</lastmod><changefreq>daily</changefreq><priority>0.2</priority></url><url><loc>http://www.mydomain.co.uk/monthly-card-gallery-competition</loc><lastmod>2013-01-21</lastmod><changefreq>daily</changefreq><priority>0.2</priority></url><url><loc>http://www.mydomain.co.uk/contact-us</loc><lastmod>2013-01-21</lastmod><changefreq>daily</changefreq><priority>0.2</priority></url></urlset>
I’ve uploaded the App/Code/Mage/Sitemap folder from an installation where the sitemap works correctly but it’s still messed up. Can anyone suggest how to fix it please as I’m stumped!
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top