Magento Forum

Nieuwe klant e-mail wordt niet verstuurd
 
vudu_3001
Jr. Member
 
Total Posts:  2
Joined:  2012-12-13
 

Hierbij een probleem waar ik werkelijk geen raad mee weet.
Ik probeer mijn webshop op te zetten en inmiddels heb ik ook de Nederlandse e-mails geupload naar de server. Zover ik kan zien worden alle e-mails correct verstuurd, behalve de nieuwe klant e-mails (account_new_confirmation.html). Ook Resend e-mails, die je kan doen indien de e-mails niet aankomen, komen niet aan. Overigens heb ik uiteraard ook mijn Spam folder vaak gecheckt, daar zitten de e-mails ook niet.

Ik heb op verschillende plaatsen e-mail ingesteld, namelijk onder:
- Systeem -> Configuratie -> Klanten -> Klant configuratie -> Standaard e-mail domein staat goed (mijndomeinnaam.nl). Standaard welkomstmail instelling staat op ‘Nieuw account (Standaard Template van Locale). Ook instellingen Bevestinglink e-mail en Welkomstmail staan op de standaard instelling. Ik ga ervan uit omdat ik Nederlandse vertaling ingesteld heb en omdat de bestanden in de juiste map geupload zijn op de server ook de Nieuw account e-mail verzonden dient te worden. Dit gebeurt dus helaas niet.

Onder instelling Systeem -> Algemeen -> E-mail adressen van winkel, heb ik ook netjes alle e-mail adressen ingevuld.

Verder heb ik onder Geavanceerd -> Systeem -> Mailinstellingen, bij Host, ook mijn domeinnaam ingevuld (mijndomeinnaam.nl).

Weet iemand toevallig wat ik over het hoofd zie. Nogmaals als ik met bijv. een testklant een nieuw account aanmaak, wordt er geen nieuwe klant e-mail verzonden. Maar bij een bestelling worden wel e-mails verzonden van de bestelling. Magento kan dus wel naar de juiste map op de server kijken en de andere e-mails worden wel verzonden.

Overigens, als ik probeer e-mails te importeren via Systeem -> Transactionele e-mails, dan is het mij gelukt om drie e-mails te importeren. Als ik bijv. Nieuwe account e-mail wil importeren dan blijft de website (oneindig) hangen (ik heb hem eens half uur laten draaien, dus hij hing dus echt). En dit gebeurt elke keer. Het is dus niet opgelost met simpelweg cache legen en opnieuw inloggen.

Ik heb verder ook verschillende e-mail templates gebruikt, om uit te sluiten dat het aan de opmaak van de e-mails ligt. Maar zlefs Nieuw account e-mails zonder css opmaak worden niet verzonden.

Wie kan mij helpen om dit vervelende probleem te tekkelen? Waar heb ik nog niet gekeken, waar heb ik nog niet aan gedacht? Of is het gewoon een bug in Magento? Maar dan dan zou het bij meer mensen spelen en zou ik verwachten het via googelen terug te vinden. En ik vond niets.

 
Magento Community Magento Community
Magento Community
Magento Community
 
vudu_3001
Jr. Member
 
Total Posts:  2
Joined:  2012-12-13
 

Echt niemand die iets soortgelijks meegemaakt heeft? Of een idee heeft wat er aan de hand zou kunnen zijn?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Richard Blezer
Jr. Member
 
Total Posts:  18
Joined:  2011-10-31
The netherlands
 

Hallo,

Ik heb dat na een update op 1.7.0.2 ook. Heb de echte oorzaak niet gevonden.
Daarvoor in de plaats heb ik ASchroder_SMTPPro geïnstalleerd . Heeft hoe dan ook meer voordelen dan de reguliere mail functie.

Tip: wij zijn allemaal vrijwilligers, niet boos worden als je niet direct hulp krijgt.

Met vriendelijke groet,

Richard Blezer

http://www.nxt-web.nl

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top