Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento connect manager file permissions? 
 
jr_zone
Jr. Member
 
Total Posts:  2
Joined:  2009-01-23
 

Hi There,

So far I like Magento and how it works. However I’m trying to install a new theme using the Magento connect manager but having some problems!

I keep getting “Error: Please check for sufficient write file permissions”

I’ve change the write permissions on the downloader folder and all folders and files within it but still get the same warning about file permissions.

I’ve been trying for ages now so I’m hoping somebody can tell me where I’m going wrong.

If I can’t sort it quickly it’s going to have to be back to one of the other carts I used.

Regards

Julie

 
Magento Community Magento Community
Magento Community
Magento Community
 
doigro
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2008-07-09
Bucharest. Romania
 

Try this: http://www.magentocommerce.com/wiki/groups/227/magento_connect

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ravikumar N B
Sr. Member
 
Avatar
Total Posts:  213
Joined:  2009-01-12
 

Better to change the owner of the magento directory.
Apache is running as nobody then

chown nobody:root ../magento/ -R

 
Magento Community Magento Community
Magento Community
Magento Community
 
CrashX
Jr. Member
 
Total Posts:  5
Joined:  2009-01-28
 

Im having the same problem… Any help?

I dont have SSH access, only FTP… plz help

Thank YOU :D

PS: I have CHMOD all files and folders to 777

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ravikumar N B
Sr. Member
 
Avatar
Total Posts:  213
Joined:  2009-01-12
 

OK.
You give permission 777 to all files and folders then it should be works.

 
Magento Community Magento Community
Magento Community
Magento Community
 
CrashX
Jr. Member
 
Total Posts:  5
Joined:  2009-01-28
 
Ravikumar N B - 13 February 2009 12:44 AM

OK.
You give permission 777 to all files and folders then it should be works.

Thx Ravikumar, that worked :D

 
Magento Community Magento Community
Magento Community
Magento Community
 
mike_hayes888
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2008-09-20
 

I’m Still having issues with this. I’ve changed all the file permissions to 777, and no luck. There are 2 options that come up when changing file permissions, There are the Permissions which i’ve change to 777 and Owner and Group? Should the Owner and group be changed. If neither any suggestions welcome…

Thanks
Mike

 
Magento Community Magento Community
Magento Community
Magento Community
 
mike_hayes888
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2008-09-20
 

YEE HAA! Think I just got it, shew that only took a day…

I changed the permissions on the downloader folder (public_html/downloader) to 755 not 777! and Hey Presto! it worked.

Hope this helps anyone else who had the problem.

Mike

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top