Magento Forum

Erro no tempo de Backup
 
gepedf
Jr. Member
 
Total Posts:  2
Joined:  2011-12-03
 

Olá pessoal,
Tento fazer o backup do meu DB através do Sistema>Ferramentas>Backups. Aparece sempre após um curto tempo, a seguinte mensagem:
Fatal error: Maximum execution time of 30 seconds exceeded in /home/portodac/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php on line 296
As vezes os erros das linhas mudam ou o arquivo PHP.
Já me falaram que teria que contactar o servidor para aumentar o tempo de 30 segundos para 3600 segundos (pois o Magento exige tempo e recursos). Eles falam que tenho que criar um php.ini e lá inserir este detalhe. Não dizem onde nem como criá-lo (acho que nem sabem sobre o Magento).
Nos fóruns, os colegas falam em alterar algumas configurações no magento ou criair o php.ini, mas não sei como e onde colocar este arquivo. Criei um site de venda de livros usados(+/- 6 meses), tenho conseguido configurar muita coisa para meu perfil, mas estou levando uma surra de todos os lados com este Backup.
Alguém pode dar uma luz em meu caminho? Ou seja, passo a passo para resolver este problema?
Agradeço antecipadamente a ajuda que vier.

 
Magento Community Magento Community
Magento Community
Magento Community
 
satish
Enthusiast
 
Total Posts:  812
Joined:  2008-03-24
34,mantri Sadan,Shivaji Nagar,Nagpur,MS,India 4400
 

Fatal error: Maximum execution time of 30 seconds:

Ask your hosting company to allow for a higher execution time.

Probable options :
1. via htaccess
2. vis php.ini
3. By code modification and changing env variable value.

Satish

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top