Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Wrong Content Type. 
 
daiwik
Jr. Member
 
Total Posts:  12
Joined:  2013-01-02
 

IN magneto 1.7.2 getting below error

a:5:{i:0;s:19:"Wrong Content Type.";i:1;s:2052:"#0 /var/www/p_dev/app/code/core/Mage/Usa/Model/Shipping/Carrier/Dhl/International.php(397): Mage::throwException(’Wrong Content T...’)
#1 /var/www/p_dev/app/code/core/Mage/Adminhtml/Model/System/Config/Source/Shipping/Allmethods.php(44): Mage_Usa_Model_Shipping_Carrier_Dhl_International->getAllowedMethods()
#2 /var/www/p_dev/app/code/core/Mage/Adminhtml/Block/System/Config/Form.php(463): Mage_Adminhtml_Model_System_Config_Source_Shipping_Allmethods->toOptionArray(false)
#3 /var/www/p_dev/app/code/core/Mage/Adminhtml/Block/System/Config/Form.php(229): Mage_Adminhtml_Block_System_Config_Form->initFields(Object(Varien_Data_Form_Element_Fieldset), Object(Mage_Core_Model_Config_Element), Object(Mage_Core_Model_Config_Element))
#4 /var/www/p_dev/app/code/core/Mage/Adminhtml/Block/System/Config/Form.php(164): Mage_Adminhtml_Block_System_Config_Form->_initGroup(Object(Varien_Data_Form), Object(Mage_Core_Model_Config_Element), Object(Mage_Core_Model_Config_Element))
#5 /var/www/p_dev/app/code/core/Mage/Adminhtml/Block/System/Config/Edit.php(92): Mage_Adminhtml_Block_System_Config_Form->initForm()
#6 /var/www/p_dev/app/code/core/Mage/Adminhtml/controllers/System/ConfigController.php(107): Mage_Adminhtml_Block_System_Config_Edit->initForm()
#7 /var/www/p_dev/app/code/core/Mage/Core/Controller/Varien/Action.php(419): Mage_Adminhtml_System_ConfigController->editAction()
#8 /var/www/p_dev/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch(’edit’)
#9 /var/www/p_dev/app/code/core/Mage/Core/Controller/Varien/Front.php(176): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#10 /var/www/p_dev/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#11 /var/www/p_dev/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#12 /var/www/p_dev/index.php(108): Mage::run(’posturite_en’, ‘store’)
#13 {main}”;s:3:"url”;s:97:"/index.php/admin/system_config/edit/section/onestepcheckout/key/db6569d97e6b43ed8ba217eed8c018b1/”;s:11:"script_name”;s:10:"/index.php”;s:4:"skin”;s:5:"admin";}

Can anyone has solution for this, i checked online i found all solution and tried also but nothing is work for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
developerindia
Member
 
Total Posts:  58
Joined:  2009-06-25
 

<carriers>
<dhlint>
<content_type>D</content_type>
</dhlint>
</carriers>

This is a Magento configuration value related bug reported here:  http://www.magentocommerce.com/bug-tracking/issue?issue=13411 and here http://www.magentocommerce.com/bug-tracking/issue?issue=13702

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top