Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

new.phtml is blank, what am I doing wrong? 
 
DjiXas
Member
 
Total Posts:  60
Joined:  2009-01-05
 

I have tried using a custom and default 1.7 theme, nothing works if I use layout with new.phtml, my home page would be empty with 0 products.

<reference name="content">
    <
block type="catalog/product_new" template="catalog/product/new.phtml">
        <
action method="setProductsCount"><count>5</count></action>
        <
action method="addColumnCountLayoutDepend"><layout>empty</layout><count>6</count></action>
        <
action method="addColumnCountLayoutDepend"><layout>one_column</layout><count>5</count></action>
        <
action method="addColumnCountLayoutDepend"><layout>two_columns_left</layout><count>4</count></action>
        <
action method="addColumnCountLayoutDepend"><layout>two_columns_right</layout><count>4</count></action>
        <
action method="addColumnCountLayoutDepend"><layout>three_columns</layout><count>3</count></action>
    </
block>
</
reference>

Any ideas? Only list works. Do I need to specify category ID? Or maybe there is a time frame? Since all products were added 1 year ago.

<reference name="content">
<
block type="catalog/product_list" name="featured" template="catalog/product/list.phtml">
<
action method="setCategoryId"><category_id>2</category_id></action>
</
block>
</
reference>
 
Magento Community Magento Community
Magento Community
Magento Community
 
Template fans
Guru
 
Total Posts:  446
Joined:  2009-11-02
 

Is your theme compatible with your magento version?

 
Magento Community Magento Community
Magento Community
Magento Community
 
DjiXas
Member
 
Total Posts:  60
Joined:  2009-01-05
 

Yes, I also tried 1.7 default theme, still same

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top