Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

layered navigation resets when you move to the next page. 
 
entllc93
Jr. Member
 
Total Posts:  25
Joined:  2012-10-15
 

when i go to a category on my site, then filter the results using layered nav, if you click on next page or page two, etc, it resets the layered nav selection, and goes to page two of all of the items in the category. it probably has something to do with my theme, but i dont know where to start. has anyone run into anything like that before?

EDIT:
i’ve noticed that it doesnt do it in search results, just the product listing. also, in the address bar, the filters are listed like the pages was pointed to the second page with the filter applied, but it ignores it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
entllc93
Jr. Member
 
Total Posts:  25
Joined:  2012-10-15
 

one of the things i have found is that in the address bar, after the .html of the page i am at, it changes it to html#!Barrel_Length=61&p;=2
when i manually change it to html?Barrel_Length=61&p;=2 with the “?” it works. so, my question is how is it doing this the wrong way?

 
Magento Community Magento Community
Magento Community
Magento Community
 
entllc93
Jr. Member
 
Total Posts:  25
Joined:  2012-10-15
 

nobody can help with this at all?

 
Magento Community Magento Community
Magento Community
Magento Community
 
entllc93
Jr. Member
 
Total Posts:  25
Joined:  2012-10-15
 

fixed. The template hints in the developer section of the admin pointed me in the right direction.

 
Magento Community Magento Community
Magento Community
Magento Community
 
msnyder12
Jr. Member
 
Total Posts:  4
Joined:  2012-08-01
 

Can you explain what you did to resolve this issue?  We are getting the exact same problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
entllc93
Jr. Member
 
Total Posts:  25
Joined:  2012-10-15
 

the was a pager.php file that controlled the paging located in app/code/local/Vinagento/Vpager/Block/Page/Html. i modified it to comment out the url replacement for #! (

#!
) . see below:

<?php
class Vinagento_Vpager_Block_Page_Html_Pager extends Mage_Page_Block_Html_Pager {
//    public function getPageUrl($page) {
//        return str_replace('?', '#&#x21;', parent::getPageUrl($page));
//    }
        
public function getPage2Url($page{
        
return str_replace('?''?'parent::getPage2Url($page));
    
}
    
}

i just commented out the top line of the function and it defaulted to the next line, worked fine.

 
Magento Community Magento Community
Magento Community
Magento Community
 
msnyder12
Jr. Member
 
Total Posts:  4
Joined:  2012-08-01
 

Awesome!  That worked perfect.  I can’t imagine of any problems that would arise from this.  I can’t believe more people don’t have this problem.

Thanks for your help.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top