Magento Forum

   
SELETTORE MULTILINGUA CON LINK SBAGLIATI
 
phonix
Jr. Member
 
Total Posts:  19
Joined:  2010-01-16
 

STO DIVENTANDO MATTO DIETRO A QUESTO PROBLEMA.

Quest è la situazione:
se inserisco manualmente l’URL delle lingue installate tutto funziona perfettamente.
(Magento mostra la homepage con la traduzione della lingua scelta e tutto funziona (ho installato 4 storeview it/fr/de/en) !)

URL INSERITE MANUALMENTE:
http://www.phonix.ch/phonixstore/ it/
http://www.phonix.ch/phonixstore/ fr/
http://www.phonix.ch/phonixstore/ de/
http://www.phonix.ch/phonixstore/ en/

Se invece seleziono la lingua dal selettore delle lingue di magento in homepage, lo stesso attiva i seguenti link che creano come risposta l’errore “sorry page not found…

URL GENERATE DAL SELETTORE DELLA LINGUA:
http://www.phonix.ch/phonixstore/en/skin/adminhtml/base/default/custom.css?___from_store=it
http://www.phonix.ch/phonixstore/it/skin/adminhtml/base/default/custom.css?___from_store=en
http://www.phonix.ch/phonixstore/de/skin/adminhtml/base/default/custom.css?___from_store=it
http://www.phonix.ch/phonixstore/fr/skin/adminhtml/base/default/custom.css?___from_store=de

DOVE POSSO CAMBIARE/SOSTITUIRE I LINK DEL SELETTORE DELLA LINGUA COSÌ DA OTTENERE LO STESSO RISULTATO CHE OTTENGO CON L’INSERIMENTO MANUALE???

GRAZIE PER QUALSIASI CONSIGLIO.....

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3456
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

piuttosto strano come url :S Comunque nella cartella del tema solitamente nella cartella page/switch/

 
Magento Community Magento Community
Magento Community
Magento Community
 
biafax
Jr. Member
 
Total Posts:  1
Joined:  2013-04-06
 

So che è passato molto tempo, ma siccome è la prima volta che sto tentando di installare Magento, mi sono imbattuto ovviamente nello stesso problema; ho trovato questa soluzione, postata qui:

http://www.magentocommerce.com/boards/viewthread/75111/#t236739

Sostanzialmente, apri /app/design/frontend/base/default/template/page/switch/languages.phtml
e modifica la linea

<option value="<?php echo $_lang->getCurrentUrl() ?>"<?php echo $_selected ?>><?php echo $this->htmlEscape($_lang->getName()) ?
></
option>
in
<option value="<?php echo $_lang->getCurrentUrl(false) ?>"<?php echo $_selected ?>><?php echo $this->htmlEscape($_lang->getName()) ?></option>

a me ha funzionato!
HTH smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3456
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

appunto: MAI fare modifiche al base.
Per ottenere lo stesso risultato in maniera più pulita semplicemente copiate il file nella cartella del tema e a quel file fate le modifiche wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
paolociucani
Jr. Member
 
Total Posts:  1
Joined:  2011-10-31
 

Salve a tutti,
anche io ho lo stesso problema, i link generati dalla funzione $_lang->getCurrentUrl() sono sbagliati come quelli di “phonix”.

nel mio caso il problema si presenta soltanto abilitado le cache, anche vuotando le cache e riattivandole il problema persiste.

Qualcuno ha lo stesso problema?

Ciao

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top