Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

install problem, can’t find any other similar errors
 
Retrofresh
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-02-01
 

After unpacking the full tar via SSH, setting the folders write permissions up as you recommend, I get onto the istall wizard fine. I click skip updates (I think this is the option i should use?) and then get to the next step of entering my database details. I check use mod_rewrite and then click for the next step and get:

Warningfile_put_contents() [function.file-put-contents]Only 0 of 1834 bytes writtenpossibly out of free disk space in /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Install/Model/Installer/Config.php on line 85
[0] in file_put_contents
("/home/default/litho.co.uk/user/htdocs/magento/app/etc/local.xml""
/home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Install/Model/Installer/Config.php on line 85
[1] in Mage_Install_Model_Installer_Config->install() in /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Install/Model/Installer.php on line 95
[2] in Mage_Install_Model_Installer->installConfig(Array[6]) in /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Install/controllers/WizardController.php on line 298
[3] in Mage_Install_WizardController->configPostAction() in /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Core/Controller/Varien/Action.php on line 336
[4] in Mage_Core_Controller_Varien_Action->dispatch("
configPost") in /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php on line 150
[5] in Mage_Core_Controller_Varien_Router_Standard->match(Mage_Core_Controller_Request_Http) in /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Core/Controller/Varien/Front.php on line 147
[6] in Mage_Core_Controller_Varien_Front->dispatch() in /home/default/litho.co.uk/user/htdocs/magento/app/Mage.php on line 379
[7] in Mage::run("
base") in /home/default/litho.co.uk/user/htdocs/magento/index.php on line 29

There was a problem proceeding with Magento installation.

Please contact developers with error messages on this page.

exception 'Zend_Controller_Response_Exception' with message 'Cannot send headers; headers already sent in /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Core/functions.php, line 152' in /home/default/litho.co.uk/user/htdocs/magento/lib/Zend/Controller/Response/Abstract.php:265
Stack trace:
#0 /home/default/litho.co.uk/user/htdocs/magento/lib/Zend/Controller/Response/Abstract.php(131): Zend_Controller_Response_Abstract->canSendHeaders(true)
#1 /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Install/controllers/WizardController.php(304): Zend_Controller_Response_Abstract->setRedirect('http://www.lith...')
#2 /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Core/Controller/Varien/Action.php(336): Mage_Install_WizardController->configPostAction()
#3 /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(150): Mage_Core_Controller_Varien_Action->dispatch('configPost')
#4 /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Core/Controller/Varien/Front.php(147): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#5 /home/default/litho.co.uk/user/htdocs/magento/app/Mage.php(379): Mage_Core_Controller_Varien_Front->dispatch()
#6 /home/default/litho.co.uk/user/htdocs/magento/index.php(29): Mage::run('base')
#7 {main}

exception 'Zend_Controller_Response_Exception' with message 'Cannot send headers; headers already sent in /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Core/functions.php, line 152' in /home/default/litho.co.uk/user/htdocs/magento/lib/Zend/Controller/Response/Abstract.php:265
Stack trace:
#0 /home/default/litho.co.uk/user/htdocs/magento/lib/Zend/Controller/Response/Abstract.php(131): Zend_Controller_Response_Abstract->canSendHeaders(true)
#1 /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Install/controllers/WizardController.php(304): Zend_Controller_Response_Abstract->setRedirect('http://www.lith...')
#2 /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Core/Controller/Varien/Action.php(336): Mage_Install_WizardController->configPostAction()
#3 /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(150): Mage_Core_Controller_Varien_Action->dispatch('configPost')
#4 /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Core/Controller/Varien/Front.php(147): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#5 /home/default/litho.co.uk/user/htdocs/magento/app/Mage.php(379): Mage_Core_Controller_Varien_Front->dispatch()
#6 /home/default/litho.co.uk/user/htdocs/magento/index.php(29): Mage::run('base')
#7 {main}

Then when I try to go back to the begining, I get:

Fatal errorCall to a member function getIdFieldName() on a non-object in /home/default/litho.co.uk/user/htdocs/magento/app/code/core/Mage/Core/Model/Abstract.php on line 118

Also having to run the php5-cgi workaround and have edited the .htaccess accordingly.

Help please?

I’d quite like to get this working this afternoon so I can have a play with it before I finish for the weekend.

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

The installer is not able to write app/etc/local.xml (local configuration settings) and gives error:

“Only 0 of 1834 bytes written, possibly out of free disk space”

Could you check that you have enough disk space on this partition?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Retrofresh
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-02-01
 

Hi, I looked at this straight away, but it’s a brand new server, and I’m using 1% of the partition, got GB’s to spare…

Thought it was the permissions, but for one attempt I tried setting EVERYTHING to 777 and still the same error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

If you say that there’s a lot of space on partition that Magento is on, and the permissions are write enabled, I’m out of guesses without looking at the system… Anyone?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Retrofresh
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-02-01
 

I’ve just successfully installed it on a local server set up in our office, so I will try and export the database/files to my remote server, and see what happens.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top