Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

mysql error
 
fishermandepot
Jr. Member
 
Total Posts:  14
Joined:  2012-04-16
 

Hi everyone, i had this error on installed a finished site into a new server. I could not figured it out. Can any one please help me on this.
Thank you very much and happy holidays.

SQLSTATE[HY000] [2002] Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)

Trace:
#0 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/lib/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/lib/Varien/Db/Adapter/Pdo/Mysql.php(313): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/lib/Zend/Db/Adapter/Abstract.php(459): Varien_Db_Adapter_Pdo_Mysql->_connect()
#3 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query(’SET NAMES utf8’, Array)
#4 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/lib/Varien/Db/Adapter/Pdo/Mysql.php(419): Zend_Db_Adapter_Pdo_Abstract->query(’SET NAMES utf8’, Array)
#5 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/Resource.php(169): Varien_Db_Adapter_Pdo_Mysql->query(’SET NAMES utf8’)
#6 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/Resource.php(110): Mage_Core_Model_Resource->_newConnection(’pdo_mysql’, Object(Mage_Core_Model_Config_Element))
#7 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(320): Mage_Core_Model_Resource->getConnection(’core_write’)
#8 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(350): Mage_Core_Model_Resource_Db_Abstract->_getConnection(’write’)
#9 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(335): Mage_Core_Model_Resource_Db_Abstract->_getWriteAdapter()
#10 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/Resource/Cache.php(53): Mage_Core_Model_Resource_Db_Abstract->_getReadAdapter()
#11 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/Cache.php(455): Mage_Core_Model_Resource_Cache->getAllOptions()
#12 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/Cache.php(497): Mage_Core_Model_Cache->_initOptions()
#13 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/App.php(1183): Mage_Core_Model_Cache->canUse(’config’)
#14 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/Config.php(414): Mage_Core_Model_App->useCache(’config’)
#15 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/Config.php(294): Mage_Core_Model_Config->_canUseCacheForInit()
#16 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/App.php(413): Mage_Core_Model_Config->loadModulesCache()
#17 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#18 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#19 /hermes/bosweb/web162/b1621/ipg.fishermandepotcom/index.php(87): Mage::run(’’, ‘store’)
#20 {main}

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

your mysql server is offline
and you have to check your settings for database.

 
Magento Community Magento Community
Magento Community
Magento Community
 
fishermandepot
Jr. Member
 
Total Posts:  14
Joined:  2012-04-16
 

The error still occurs on www. fishermandepot.com.... Does anyone have any idea?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Prohost_be
Jr. Member
 
Avatar
Total Posts:  26
Joined:  2011-10-13
 

Looks like your running on a Cpanel enabled server.
Tried loggin into WHM ? and restarting mysql?

 
Magento Community Magento Community
Magento Community
Magento Community
 
gordo147
Jr. Member
 
Total Posts:  8
Joined:  2013-03-27
 

Does anyone know if restarting my MySQL in WHM worked for this?

I’m having a similar problem, the websites index and admin panel aren’t viewable, and when i do a server check I get “MySQL: The MySQL seems to be offline” - it started after i edited a products meta tag now the site is offline?!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top