Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Magento - Backend Perfect, Frontend - all of the links are broken? 
 
MindWerks
Jr. Member
 
Total Posts:  9
Joined:  2008-01-29
 

After installing Magento, and sucessfully getting the sample sql imported I’ve run into a problem with the frontend, namely that all of the links off the front page are broken.

If you go to https://www.1stflight.net/magento (yes it’s a self signed certificate) you’ll see the problem I’m running into. The shopping cart, wishlist, all return a file not found error.

Can anyone see what I’ve missed in my install?
Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

You have setup your secure base url as https://1stflight.net/magento/ which is broken.
Set it to https://www.1stflight.net/magento/

 
Magento Community Magento Community
Magento Community
Magento Community
 
MindWerks
Jr. Member
 
Total Posts:  9
Joined:  2008-01-29
 

I made the change under “Magento Admin” > System > Configuration > Web and the errors persist. Any other ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Clean all cache in Admin > System > Cache Management

 
Magento Community Magento Community
Magento Community
Magento Community
 
MindWerks
Jr. Member
 
Total Posts:  9
Joined:  2008-01-29
 

Doesn’t appear to be any change, unfortunately.

Not Found

The requested URL 
/magento/checkout/cartwas not found on this server.
Apache/2.2.4 (UbuntuPHP/5.2.3-1ubuntu6.3 mod_ssl/2.2.4 OpenSSL/0.9.8e Server at www.1stflight.net Port 443

And the error.log file has entries like this:

x.x.x.- - [31/Jan/2008:21:56:57 -0500] "GET /magento/skin/frontend/default/default/images/footer_info_separator.gif HTTP/1.1" 200 51 "https://www.1stflight.net/magento/skin/frontend/default/default/css/boxes.css" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11"
 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Maybe you have chosen to use Apache rewrites, but do not have mod_rewrite enabled.

Admin > System > Configuration > Web > Use Apache Rewrites - set to No

 
Magento Community Magento Community
Magento Community
Magento Community
 
MindWerks
Jr. Member
 
Total Posts:  9
Joined:  2008-01-29
 

BINGO!!! That did the trick! Thank you!

So what does mod_rewrite do and why did it have that effect?

Thanks again!

 
Magento Community Magento Community
Magento Community
Magento Community
 
kameko.rouge
Member
 
Total Posts:  58
Joined:  2007-10-11
 

uh it rewrites your urls?

 
Magento Community Magento Community
Magento Community
Magento Community
 
yoyo
Jr. Member
 
Total Posts:  1
Joined:  2008-02-03
 

Hello,

my installation has a similar problem: the rewritten urls are not working in the front end (they are rewritten), unless they are behind index.php in the url:

eg.: not working: http://localhost/catalog/seo_sitemap/category/
working: http://localhost/index.php/catalog/seo_sitemap/category/

If I add the index.php to the Base Link URL (in the admin section):

{{unsecure_base_url}}index.php/

the index.php shows up in some links, but ... not in all.

For example, on the main page “http://localhost/customer/account/”
or “http://localhost/customer/account/login/” does not include the base link (and are not working either way anyway).

Also it will work for some links like “http://localhost/index.php/checkout/cart/”
but not for “http://localhost/index.php/wishlist/” which will give a HTTP 404 Error.

Is there some explanation for this “some are working, some are not”?

I might add, that http://localhost/ points to index.php (Apache httpd.conf “DirectoryIndex index.php") and I do not understand, why “basedirectory/” and the “basedirectory/index.php” behaves differently.

I added the output of phpinfo to this post.

Kind regards

Martin von Hermanni

File Attachments
phpinfo.htm  (File Size: 57KB - Downloads: 546)
 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@yoyo:
1. restore “Base Link Url” = {{unsecure_base_url}}
2. set “Use Web Server Rewrites” = “No”

 
Magento Community Magento Community
Magento Community
Magento Community
 
freerange
Jr. Member
 
Total Posts:  5
Joined:  2008-02-22
 

I am having a very similar problem.
My phpinfo() shows that mod_rewrite is enabled and I have tested by putting mod_rewrite directives in other directories and am not getting any errors. I even put a simple rule to redirect everything to a different php program and it is doing that. The basic links work if I disable mod_rewrite in the admin panel, but it should work.

I have installed on two other Linux servers without any problems. It it possible that there is an issue with my host providing the proper base directory?

Any insight or ideas would be appreciated.

-Derrick

I am attaching my phpinfo() results…
Magento version 0.8.161
Linux 2.6.9
Apache 2.0
PHP 5.2.5
MySQL 4.1.22

File Attachments
getphpinfo.php.htm  (File Size: 80KB - Downloads: 127)
 
Magento Community Magento Community
Magento Community
Magento Community
 
freerange
Jr. Member
 
Total Posts:  5
Joined:  2008-02-22
 

FIXED
http://www.magentocommerce.com/boards/viewthread/3788/

 
Magento Community Magento Community
Magento Community
Magento Community
 
atlantide
Sr. Member
 
Avatar
Total Posts:  187
Joined:  2008-02-16
France
 

hello,

I have the same problem, URL are :
/magento/customer/account/

but not :
/magento/index.php/customer/account/

I did not change Base Link Url.
I set “Use Web Server Rewrites” = “No”

Then some links works now (login, cart, checkout), but some other are still broken, like “login” :
/magento/customer/account/login/

what should I do ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
atlantide
Sr. Member
 
Avatar
Total Posts:  187
Joined:  2008-02-16
France
 

any idea ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

When I try to go to your site home page and then click on the login link
I got to this page http://79.170.40.42/drieu-titoon.fr/magento/index.php/customer/account/login/ and it is working just fine.
Try to clean your cache in the browser and system cache.
It looks like that after you disabled the rewrite in the admin, browser still have your login page cached so it is taking you to the user friendly page

 
Magento Community Magento Community
Magento Community
Magento Community
 
atlantide
Sr. Member
 
Avatar
Total Posts:  187
Joined:  2008-02-16
France
 

Thank you, you’re right, I had already resolve the problem, with the help of Moshe.

I did it exactly the way you said.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2