Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problème d’affichage des totaux dans checkout_ongepage_review
 
Gregory Tonon
Member
 
Avatar
Total Posts:  65
Joined:  2008-03-27
Toulouse
 

Bonjour tout le monde,

Pour les besoins d’un client j’ai du surcharger le processus de commande en quasi totalité.

Maintenant lorsque j’arrive à l’étape de récapitulatif de commande ( review ), le montant total des frais de port ne s’affiche plus.

En faisant une débug la partie se chargeant de l’affichage des totaux ( block Mage_Checkout_Block_Cart_Totals, fonction renderTotal comme çeci :

public function renderTotal($total$area null$colspan 1)
    
{
        print_r
($total);
        if(
$this->_getTotalRenderer($total->getCode())){
            
return $this->_getTotalRenderer($total->getCode())
                ->
setTotal($total)
                ->
setColspan($colspan)
                ->
setRenderingArea(is_null($area) ? -$area)
                ->
toHtml();
        
}
    }

Voici ce que j’obtiens :

Mage_Sales_Model_Quote_Address_Total Object [_data:protected] => Array ( [style] => subtotal [code] => subtotal [title] => Hors Taxes [value] => 334.44 [_origData:protected] => [_idFieldName:protected] => [_isDeleted:protected] => ) Mage_Sales_Model_Quote_Address_Total Object [_data:protected] => Array ( [code] => tax [title] => TVA [full_info] => Array ( [FR-TVA-normale] => Array ( [rates] => Array ( [0] => Array ( [code] => FR-TVA-normale [title] => TVA 19,6[percent] => 19.6 [position] => 1 [priority] => ) ) [percent] => 19.6 [id] => FR-TVA-normale [process] => 0 [amount] => 65.56 [base_amount] => 65.56 ) ) [value] => 65.56 [_origData:protected] => [_idFieldName:protected] => [_isDeleted:protected] => )

On voit clairement que le shipping_total n’apparait pas dans la liste des totaux à afficher

Je ne sais pas ce que j’ai oublié de faire afin d’avoir l’affichage des frais de port.

Si quelqu’un a une piste à me fournir je suis preneur car ça fait plusieurs heures que j’essaye de trouver mon erreur mais n’y arrive pas!

Merci à tous d’avance

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top