Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Odd problem with Multiple Domains
 
Thejosh13
Sr. Member
 
Total Posts:  252
Joined:  2008-06-23
 

I am trying to set up multiple domains, on a Virtual Dedicated Goddady account. I have a live main store on domain1.com, and then installed a 2nd store looking up to the main domain1’s database. I changed the index files and added htaccess

On the main domain I created a sub directory for domain2.com, and used symbolic links for the sub directory to point the skin and media files to the main domain1.com directory.

I have the Base URL as: domain1.com/
and the base link as: domain2.com/

The problem is:
When I am on domain2.com everything will link to domain1.com

So then when I click a link I am transferred to domain1.com. Then once I am on Domain1.com now every link points back to domain2.com. All while in the same domain2.com store.

On the design tab I can change the folder theme for skin, and it will reflect it on domain1.com (while in the domain2 store), but will not change to the right folder for domain2.com (which looks up its skin on the main domain). So basically I can not change which skin theme to use in the admin.

No media images will show.

I have refreshed cache through the main sites admin and don’t think this is it

 
Magento Community Magento Community
Magento Community
Magento Community
 
Thejosh13
Sr. Member
 
Total Posts:  252
Joined:  2008-06-23
 

I waited 9 hours overnight, and now the skin updated on domain2.com.

Are there 2 separate caches for each site? I installed the full magento on domain2.com, do I need to delete something to make sure it does not cache anything over there?

Category links still bounce between the 2 domains, but I had been playing with the settings so this may be updated in a couple hours when everything goes through....

Product Images are not showing up, but they are looking up to domain1.com correctly for the placeholder

 
Magento Community Magento Community
Magento Community
Magento Community
 
Incognito
Guru
 
Total Posts:  322
Joined:  2008-08-07
Michigan
 

I use the Subdirectory Method.
http://www.crucialwebhost.com/blog/how-to-setup-multiple-magento-stores/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top