Magento Forum

   
hilfe, kann installation nicht starten
 
Grossmutter
Jr. Member
 
Total Posts:  5
Joined:  2012-11-28
 

hallo @all,
ich bin neu hier und völliger magento-newbie. ich habe zwar schon mit os- bzw. xt- commerce gearbeitet und das lief ganz gut, aber bei magento scheitere ich schon an der installation.
V. 1.7.0.2 downgeloadet und entpackt, auf server hochgeladen in ein unterverzeichnis /shop
bei aufruf passsiert genau nix, von der 404-seite mal abgesehen, so daß eine weitere installation und konfiguration gar nicht erst möglich wird. servervoraussetzungen müßten passen.
hat jemand einen hinweis zur fehlereingrenzung?
neu hochladen wurde natürlich auch schon ausprobiert, mit demselben effekt.
danke schon mal im voraus
lg helga

 
Magento Community Magento Community
Magento Community
Magento Community
 
janosch12
Member
 
Total Posts:  66
Joined:  2011-01-29
Radcliff
 

welche Fehlermeldung gibt es den ?,
mach doch mal einen Screen

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siggi_Schmitz
Enthusiast
 
Avatar
Total Posts:  811
Joined:  2011-07-03
 

Befindet sich eine .htaccess im Shop - Verzeichnis?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Grossmutter
Jr. Member
 
Total Posts:  5
Joined:  2012-11-28
 

danke für die hilfsbereitschaft.

diese meldung kommt, wenn man die seite (liegt in einem unterverzeichnis /magento/) aufruft:

> Internal Server Error
> The server encountered an internal error or misconfiguration and was unable to complete your request.
>
> Please contact the server administrator, admin and inform them of the time the error occurred, and anything you might have done that may
> have caused the error.
>
> More information about this error may be available in the server error log.
>
> Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

ich habe dann mit magento-check.php geprüft und dieses ergebnis bekommen:

Notice: Undefined offset: 0 in /home/.sites/798/site1467/web/magento-check.php on line 30
Your server does not meet the following requirements in order to install Magento.
The following requirements failed, please contact your hosting provider in order to receive assistance with meeting the system requirements for Magento:

You need MySQL 4.1.20 (or greater)
The following requirements were successfully met:
You have PHP 5.2.0 (or greater)
Safe Mode is off
You have the curl extension
You have the dom extension
You have the gd extension
You have the hash extension
You have the iconv extension
You have the mcrypt extension
You have the pcre extension
You have the pdo extension
You have the pdo_mysql extension
You have the simplexml extension

das sollte aber nicht stimmen, denn lt. provider ist eine mysql version jenseits der 5. auf dem server....

wäre toll, wenn hier jemand die lösung für das problem wüßte, mit “suche” bzw googeln habe ich bis jetzt nicht wirklich was gefunden, das das problem trifft.

danke & lg

 
Magento Community Magento Community
Magento Community
Magento Community
 
Grossmutter
Jr. Member
 
Total Posts:  5
Joined:  2012-11-28
 

nachtrag zum letzten post:

so sieht meine .htaccess aus:

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

# Action php5-cgi /cgi-bin/php5-cgi
# AddHandler php5-cgi .php

############################################
## GoDaddy specific options

# Options -MultiViews

## you might also need to add this line to php.ini
## cgi.fix_pathinfo = 1
## if it still doesn’t work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

# php_value memory_limit 64M
php_value memory_limit 256M
php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter on all content
###SetOutputFilter DEFLATE
# Insert filter on selected content types only
#AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

# Netscape 4.x has some problems…
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

# Don’t compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don’t deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

RewriteBase /magento/

############################################
## uncomment next line to enable light API calls processing

RewriteRule ^api/([a-z][0-9a-z_]+)/?$ api.php?type=$1 [QSA,L]

############################################
## rewrite API2 calls to api.php (by now it is REST only)

RewriteRule ^api/rest api.php?type=rest [QSA,L]

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## TRACE and TRACK HTTP methods disabled to prevent XSS attacks

RewriteCond %{REQUEST_METHOD} ^TRAC[EK]
RewriteRule .* - [L,R=405]

############################################
## redirect for mobile user agents

#RewriteCond %{REQUEST_URI} !^/mobiledirectoryhere/.*$
#RewriteCond %{HTTP_USER_AGENT} “android|blackberry|ipad|iphone|ipod|iemobile|opera mobile|palmos|webos|googlebot-mobile” [NC]
#RewriteRule ^(.*)$ /mobiledirectoryhere/ [L,R=302]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault “access plus 1 year”

</IfModule>

############################################
## By default allow all access

Order allow,deny
Allow from all

###########################################
## Deny access to release notes to prevent disclosure of the installed Magento version

<Files RELEASE_NOTES.txt>
order allow,deny
deny from all
</Files>

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none

danke & lg

 
Magento Community Magento Community
Magento Community
Magento Community
 
cwschneider
Sr. Member
 
Avatar
Total Posts:  88
Joined:  2008-10-20
Koblenz
 

Hi

Du schreibst “im Unterverzeichnis /shop”.
Gleichzeitig hast du in der .htaccess aber die RewriteBase auf /magento.

Das macht wenig Sinn, trag dort auch mal /shop ein.

Viele Grüße,
Christian.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Grossmutter
Jr. Member
 
Total Posts:  5
Joined:  2012-11-28
 

hallo,
das stimmt schon, /magento/ ist richtig.
/shop/ war bei meinen ersten versuchen das unterverzeichnis, danach habe ich mit neuem download auf zwei verschiedenen domains mit unterverzeichnis magento probiert. in beiden fällen, wie beschrieben, das ergebnis, daß die installation nicht gestartet wird, obwohl angeblich alle bedingungen erfüllt sind.
ich bin nach wie vor ratlos, finde auch mit googeln in anderen foren keine hinweise…
was kann man zum experimentieren alles noch auskommentieren in der .htaccess? hab mich da nur an die diversen rewrite-angaben gewagt, das hatte aber überhaupt keine auswirkungen.
danke&gru;ß
helga

 
Magento Community Magento Community
Magento Community
Magento Community
 
cwschneider
Sr. Member
 
Avatar
Total Posts:  88
Joined:  2008-10-20
Koblenz
 

Hallo

Würde als nächstes Mal die folgende Zeile
Options +FollowSymLinks
auskommentieren.

Ansonsten schreib mir mal eine PM.

Viele Grüße,
Christian.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Grossmutter
Jr. Member
 
Total Posts:  5
Joined:  2012-11-28
 

danke, christian, das hat geholfen smile

leider war die freude nur von kurzer dauer, denn nach dem ersten schritt in der configuration komme ich nur bis zur eingabe der db etc., dann gehts nicht mehr weiter:

Database server does not support the InnoDB storage engine.

damit scheints für mich offensichtlich, daß mein provider nicht darauf eingestellt ist, daß wer magento installiern will… leider kommt von dort auch keine brauchbare rückmeldung…

noch wer eine idee, was ich tun kann?

danke & lg

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top