Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Nach Serverumzug bei Strato Magento CSS defekt
 
latinostar
Sr. Member
 
Total Posts:  99
Joined:  2009-09-10
 

GELÖST, Siehe unten
______
Hallo Community,

ich habe einen Serverumzug innerhalb von Strato getätigt; allerdings wird der Administrationsbereich und alles andere nicht richtig dargestellt.
Zudem, wenn man auf einen Link klickt, öffnet sich der gewünschte Link ohne einem “/” vor der “index.php”, sodass man es nur anzeigen lassen kann, wenn man den Slash eigenhändig einfügt.

Im Administratorenbereich kann ich deswegen auch nicht den Cache leeren oder andere Befehle ausführen.

Zur Vorgeschichte:

- Ich habe den Shop von einem PowerPaket bei Strato zu einem ManagedServer übertragen.

- Die Datenbank habe ich bei Strato exportiert und dann eine neue Datenbank erstellt und dort den Export eingespielt, was erst nicht klappte, da in der Datenbank eine “Create-Anweisung” war. Die Anweisung habe ich gelöscht und dann hat das Einspielen der Datenbank einwandfrei geklappt - so wie es aussieht…
- Da ich auf die Seiten nicht zugreifen konnte, bin ich dem Tipp nachgegangen, dass man alle Rechte auf 777 setzen solle (Ordner & Dateien).
Das hatte jedoch nichts gebracht und ich bin folgender Anleitung nachgegangen: http://www.schulterzentrum-saar.de/index.php/magento-installation-auf-strato-server.html
Speziell hat das geholfen: Die .htaccess Datei muss vor dem Installationsaufruf also zunächst manuell umgeändert werden. Einfach in der Textzeile “FollowSymLinks” gegen “SymLinksIfOwnerMatch” tauschen.
Habe dann im Anschluss mit dem Magento-Cleanup-Script alle Rechte wiederhergestellt (ob das Ordnungsgemäß geklappt hat, kann ich nicht 100% bestätigen, aber alle Dateien und Ordner haben jetzt wieder die richtigen Rechte)..

Über Hilfe würde ich mich sehr freuen und dankbar sein, da ich echt nicht mehr weiter weiß!

Schöne Grüße!
_______________
GELÖST:
Es war ein peinlicher Fehler, ich hatte bei der Datenbank die URL nicht mit einem Slash als Ende versehen. Also http://musterdomain.de anstelle http://musterdomain.de/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top