Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Basic theme creation
 
manzell
Jr. Member
 
Total Posts:  7
Joined:  2012-11-18
 

I’m having a big problem trying to create a custom theme under magento 1.7.x

I’ve made a very simple theme.

I’ve created the following folders:

/skin/frontend/default/battleship-theme
/skin/frontend/default/battleship-theme/css
/skin/frontend/default/battleship-theme/images

/app/design/frontend/base/default/battleship-theme
/app/design/frontend/base/default/battleship-theme/layout
/app/design/frontend/base/default/battleship-theme/template

There are only two files in the theme - a styles.css file in /skin/frontend/default/battleship-theme/css and a local.xml in /app/design/frontend/base/default/battleship-theme/layout

In my magento configuration [system->configuration->design] current package is set to default and Translations, Templates, Skin and Layout are set to battleship-theme.

All caching is turned off/flushed.

Can anyone tell me why my styles.css are not being utilized and the local.xml file is being ignored? Thank you very much!

 
Magento Community Magento Community
Magento Community
Magento Community
 
tzyganu
Mentor
 
Avatar
Total Posts:  2205
Joined:  2009-11-18
Bucharest, Romania
 

Your local.xml file is ignored because you created these folders:
app/design/frontend/base/default/battleship-theme
/app/design/frontend/base/default/battleship-theme/layout
/app/design/frontend/base/default/battleship-theme/template

They should be:
app/design/frontend/default/battleship-theme
/app/design/frontend/default/battleship-theme/layout
/app/design/frontend/default/battleship-theme/template

Remove the ‘base’ folder.

Also check if you have other settings in system->configuration->design at the store view level.
I assume you added the settings for scope ‘global’.

Marius.

 
Magento Community Magento Community
Magento Community
Magento Community
 
manzell
Jr. Member
 
Total Posts:  7
Joined:  2012-11-18
 

Thanks Marius

I made folders in /app/design/frontend/default/battleship-theme and /skin/frontend/default/battleship-theme (my previous post had a typo)

I’ve updated my configuration to under the “default config” scope to use the package ‘default’ and use ‘battleship-theme’ for all theme options other than ‘defaut’. There is no “global” scope available to me, although I presume default config is that scope as it is the first item. Under all other scopes, I’ve removed any values under Themes.

However, Magento still rolls back to the default Magento theme.  I’ve attached screenshots of the file structure and my magento config.

Thanks again for the help!

Image Attachments
magento1.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
manzell
Jr. Member
 
Total Posts:  7
Joined:  2012-11-18
 

and the file structure…

Image Attachments
magento2.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
tzyganu
Mentor
 
Avatar
Total Posts:  2205
Joined:  2009-11-18
Bucharest, Romania
 

this is strange.
It seams that you are doing it right.
Did you clear the cache?

Here is an other possible problem.
It happened to me once after inheriting a website on Magneto.
Under system->design there was an entry that overrides the settings under system->configuration->web.
If you have something under system->design, delete everything.

That’s the last idea I have.

Marius.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top