Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Upload HTTP Error only on product images
 
mluce194
Jr. Member
 
Total Posts:  6
Joined:  2012-10-28
 

Hello,

I know this bug has been debated before but even by going through all the discussions and trying everything that was mentionned, I cannot fix the issue.

Everytime I try to upload a product image, it seems for half a second that the upload is working since I have a 100% uploading message but then I get this error: Upload HTTP Error.

In order to fix this, I tried the following actions:

- I checked the permission of my media and skin folders. They are all set to 777 chmod.
- I checked on the root .htaccess file that SecFilterEngine and SecFilterScanPOST are set to off.
- I checked that there is no .htpasswd protection.
- I checked that Validate HTTP_USER_AGENT is set to \\\"No\\\" in System --> Configuration --> Web --> Session Validation Settings
- I cleared all the cache numerous times
- I updated Flash player to the latest version
- I disabled all the modules to check if there was any conflict with the uploading module: it made no difference even after clearing the cache.

What surprises me is that I have no problem uploading images for categories, it is only for product images. It cannot be a server limit issue because I tried uploading even very small files and I got the same result.

Please, I am getting a bit desperate here, if you could help me find a solution, I would be very grateful…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Store_Manager
Enthusiast
 
Avatar
Total Posts:  867
Joined:  2012-07-09
 

Hello,

I see that you\’ve checked a lot of things. Maybe there is some issue with the files which are in charge for the image upload. Check the files of default Magento.

Also please specify, this issue occurred recently and after certain change or it was all the time?

Hope you manage to discover solution for the issue. In meanwhile I suppose that you need the tool for proper image load in order not to miss the season and prepare for the holidays.  In case you are interested in the one, I can offer you 14-days free version of Store Manager for Magento application -
http://www.magentocommerce.com/magento-connect/store-manager-for-magento.html
At least can serve as you as temporary means of data management.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mluce194
Jr. Member
 
Total Posts:  6
Joined:  2012-10-28
 

The issue has been there all the time: I have just installed Magento and I found out about this issue when I was trying to create some new products for the first time. The only things I installed are Magento 1.7.0.2 and then the Blanco Magento theme. I don’t see how this could prevent image upload from working.

I did check the Magento files and I did not find anything special.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Store_Manager
Enthusiast
 
Avatar
Total Posts:  867
Joined:  2012-07-09
 

Hi again Mluce194,

In this case I recommend you to try out Store Manager for Magento to make sure that this issue is not related to your database. The application connects directly to database skipping admin files, so in case you will be able to upload the product image using Store Manager, it will most likely denote, that currently you have the issue with your admin files.

Also it can serve you as temporary solution for managing store and in meanwhile you can discover the issue with product images more deeply.

Let me know your experience.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tzyganu
Mentor
 
Avatar
Total Posts:  2205
Joined:  2009-11-18
Bucharest, Romania
 

Hello
Maybe this helps
http://marius-strajeru.blogspot.ro/2011/09/upload-issue-for-magento-1600.html
Even if from the title you can conclude the solution is for Magento 1.6, I was able to fix this on 1.7 also.

Cheers,
Marius.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mluce194
Jr. Member
 
Total Posts:  6
Joined:  2012-10-28
 

Thank you very much for the tip. However, I did try to switch to Prototype 1.6 and it did not work for me, even after I cleared all the cache.

I really do not know what I am missing here!

 
Magento Community Magento Community
Magento Community
Magento Community
 
mluce194
Jr. Member
 
Total Posts:  6
Joined:  2012-10-28
 

So now I am trying to look at all the files involved in order to track back to what is wrong. I found out that the error code I get comes from the flexuploader.js file. Below is the code:

errorText: function(file{
            
var error '';

            switch(
file.errorCode{
                
case 1// Size 0
                    
error 'File size should be more than 0 bytes';
                    break;
                case 
2// Http error
                    
error 'Upload HTTP Error';
                    break;
                case 
3// I/O error
                    
error 'Upload I/O Error';
                    break;
                case 
4// Security error
                    
error 'Upload Security Error';
                    break;
                case 
5// SSL self-signed certificate
                    
error 'SSL Error: Invalid or self-signed certificate';
                    break;
            
}

            
if(error{
                
return this.translate(error);
            
}

            
return error;
        
}

So what I get is the error code number 2 “Upload HTTP error”. Now, what I would like to understand is what the file.errorCode variable refers to. I wish i could find another file where the error code is detailed but I am not even sure there is one. I am more of a designer than a developer, so is there anyone who could help me?

 
Magento Community Magento Community
Magento Community
Magento Community
 
mluce194
Jr. Member
 
Total Posts:  6
Joined:  2012-10-28
 

Ok, so since I was pretty desperate, I made a whole fresh install of Magento 1.7 without even adding sample data or a new theme. Well, the problem is still there. So I made the exact fresh install on another server and, guess what ? This time, I was actually able to upload a product image. So the only conclusion I can find is that it is a server issue, although I have no idea what issue it is exactly and how to change that. What is weird is that, on the server where it does not work, I do not even get a temp directory created. And I do have my media directory permissions set to chmod 777. Does anyone have any idea why it would not work on some servors, and what I could do about that?

 
Magento Community Magento Community
Magento Community
Magento Community
 
mluce194
Jr. Member
 
Total Posts:  6
Joined:  2012-10-28
 

Ok, now I have noticed I am having some trouble saving content on CMS pages as well: the content does not get saved if it is too long. I changed the database requirements but the issue is still here. I do not have this issue with the other server where the image upload would also work. Do you think these two problems, the image uploading and the content saving, can be caused by the same server configuration issue? The problem is I do not have any control over it. I talked to the technical person who does but he does not seem to understand the issue either. I know you people lost interest in my thread but I wish I could get some advice from users who had the same server issue…

 
Magento Community Magento Community
Magento Community
Magento Community
 
blinblin
Jr. Member
 
Avatar
Total Posts:  29
Joined:  2009-08-02
 

same problem, what to do ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
danwebfeet
Jr. Member
 
Total Posts:  3
Joined:  2013-03-20
 

I know this is a bit late but often this can often be related to the FcgidMaxRequestLen in your apache configuration.

 
Magento Community Magento Community
Magento Community
Magento Community
 
puneetdwd
Jr. Member
 
Total Posts:  1
Joined:  2013-10-10
 

Hello,

I am facing the same problem. I have checked all the things described in the above discussion but problem is still there.
Please let me know what to do now????

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
sunilcse24
Jr. Member
 
Total Posts:  1
Joined:  2012-04-30
 

Hi,

I have faced the same issue but i had solved by installing an extension called No flash Image Uploader http://www.magentocommerce.com/magento-connect/no-flash-image-uploader.html

Cheers,
Sunil George

 
Magento Community Magento Community
Magento Community
Magento Community
 
riskfreerepair
Jr. Member
 
Total Posts:  4
Joined:  2014-04-25
 

Overview=Resize, compress or modify your photos to be less than 128kb in size.

I have a fix, I guarantee this will work for you. Just goes to show that thinking outside the box and seeking for alternative ways around problems does pay off.

I searched all over online for answers, I’ve read numerous threads and this is what I’ve figured out:

The error only occurs when you are trying to upload files larger than 128kb.

So, the fix is a simple two step process:

Upload your photo to http://www.picresize.com/

Click continue

Once uploaded, make sure “50% smaller is set for Step #2” You can play with this later but you may still get the HTTP error even though the file size is less than 128kb. I’m not really sure how that works but I’ve noticed the image quality is identical even after the compression so that may have something to do with it.

IMPORTANT: In the bottom right corner of step #4 enter 128 for “Max Filesize”

Click “I’m done, resize my picture!”

That’s it! Now try uploading your picture! Please visit my site at www.riskfreerepair.com and look around, sign up to the forums and possibly get your computer repaired risk free!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top