Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento Connect 403 error : my extension can’t be downloaded
 
hector_j
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2012-08-08
Ho Chi Minh
 

My free extension just got approved, so me and some of my friends tried to download it via Magento Connect 2.0 to see if it works… and it doesn’t.
If you go directly to the extension key URL ( http://connect20.magentocommerce.com/community/module-factory-hj/ ), you get a 403 error.

I tried via this web service : http://freegento.com/ddl-magento-extension.php and I get a “failed : cannot get xml” error.

I tried on one of my local magento, with magento connect manager, and I got “community/module: No releases for ‘module’, skipping”

The last error make me think that there could be a problem with the “-”, but I can’t change my magento key, and it maybe something else…

Does anyone already got this error ?
And, most important, does anyone have an idea to fix it ?

Thank you for your interest in my problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hector_j
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2012-08-08
Ho Chi Minh
 

I did that…
\"Thank you for your contribution. If you are not able to install the extension in your Community Edition install, the issue could relate to having your extension packaged incorrectly. Please verify and resubmit.\”

Not a clue about what could have been done wrong… I keep searching, and I\’ll post the fix if I find one.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hector_j
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2012-08-08
Ho Chi Minh
 

I join my package to that post if someone wants to check it.
I checked everything.
The channel is set to “community”, I selected “1.5.0 & later”, the release stability is set to “stable"…

I’m pretty sure it’s a problem with the “-”, so I need Magento team to change that extension key for me as it is locked.

File Attachments
module-factory-hj-0.1.0.tgz  (File Size: 163KB - Downloads: 38)
 
Magento Community Magento Community
Magento Community
Magento Community
 
hector_j
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2012-08-08
Ho Chi Minh
 

I have to add that I tried to upload manually my package on 1 of my Magento installation, and it works.
So it’s really a problem with Magento Connect server.

(and this have nothing to do with my problem, but there is a bug in this forum : when you fail the captcha and come back to the “new reply” page, it adds a backslash before every quote)

 
Magento Community Magento Community
Magento Community
Magento Community
 
hector_j
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2012-08-08
Ho Chi Minh
 

I reposted my extension ( http://www.magentocommerce.com/magento-connect/catalog/product/view/id/15153/s/hj-module-factory-5861/?___store=mc_default_store ) with a new extension key (without any “-") and now it works, so that was the problem.

If a Magento team member read this : it could be good to add a check for “-” when the developer post his extension.

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top