Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Migrated to different domain but Admin won’t work
 
Next2Heaven
Jr. Member
 
Total Posts:  4
Joined:  2007-12-13
 

I’ve migrated over Magento on the same server but a different domain name (moved the files too).  I’ve updated the core_config_data table paths for ‘web/secure/base_url’ and ‘web/unsecure/base_url/’.

The shopping cart is working but the admin area is not.  It loads half the html page for the login but stops right after the password field.  I’ve looked at the source code and it looks like none of the css/js files are using the full path.  They start like: ‘/adminhtml/default/...’.

What else do I need to edit to have the full paths to these files so the admin can work?

 
Magento Community Magento Community
Magento Community
Magento Community
 
S Macfarlane
Member
 
Avatar
Total Posts:  53
Joined:  2010-10-24
Southampton
 

You need to make sure you have update all the of the values not just those two. Here is the command I run just replace your domain.

UPDATE core_config_data SET value="http://www.yourdomain.com/" WHERE path=’web/unsecure/base_url’;
UPDATE core_config_data SET value="http://www.yourdomain.com/" WHERE path=’web/unsecure/base_link_url’;
UPDATE core_config_data SET value="http://www.yourdomain.com/skin/" WHERE path=’web/unsecure/base_skin_url’;
UPDATE core_config_data SET value="http://www.yourdomain.com/media/" WHERE path=’web/unsecure/base_media_url’;
UPDATE core_config_data SET value="http://www.yourdomain.com/js/" WHERE path=’web/unsecure/base_js_url’;

Also don’t forget to clear our your var/cache folder. If you have a custom media URL for your CDN then you should ignore the 4th line above.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Next2Heaven
Jr. Member
 
Total Posts:  4
Joined:  2007-12-13
 

Strange....I don’t have those other values in that table.  This was built a month ago so it’s a fairly recent build.  Thoughts?

 
Magento Community Magento Community
Magento Community
Magento Community
 
S Macfarlane
Member
 
Avatar
Total Posts:  53
Joined:  2010-10-24
Southampton
 

This was the guide I followed previously:

http://www.magentocommerce.com/wiki/groups/227/moving_magento_to_another_server

You also need to make sure any cache you have is purged, file cache in “var/cache” and memcache to name a few.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Next2Heaven
Jr. Member
 
Total Posts:  4
Joined:  2007-12-13
 

Ya...done all that.  Very strange.  Cache is cleared and everything.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bond007
Jr. Member
 
Total Posts:  2
Joined:  2010-12-09
 

.

 
Magento Community Magento Community
Magento Community
Magento Community
 
S Macfarlane
Member
 
Avatar
Total Posts:  53
Joined:  2010-10-24
Southampton
 

I’m happy to have a look on a desktop shared session if you want using something like http://www.join.me?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top