Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Indexing issue
 
Horatiu Taina
Member
 
Avatar
Total Posts:  42
Joined:  2008-08-22
 

Hi guys,

I have recently counted 167 attributes in my new platform, where I have 51 filterable.

It’s more than obvious, that the problem is the Product Flat Data indexing.

I have checked out the error.log and I get the following:

Exception messageSQLSTATE[42000]Syntax error or access violation1118 Row size too largeThe maximum row size for the used table typenot counting BLOBsis 65535. You have to change some columns to TEXT or BLOBs

I studied the issue on the Internet… and found Sonassi’s solution: LINK

But his solution is out of date / version.

So… I would like to change the way the indexing is done. I have to keep all the attributes. When the catalog_product_flat_1 is created, the main problem is the row size of the table. I want to tell Magento to create columns that are varchar(255) with varchar(64) instead.

Where is the file that does that, so that I can change the size of the column?

Thank you,
HTaina

 
Magento Community Magento Community
Magento Community
Magento Community
 
Horatiu Taina
Member
 
Avatar
Total Posts:  42
Joined:  2008-08-22
 

By the way…

I switched ‘Used in product listing’ to “NO” for my attributes… Reindexing works fine now.

But still… there should be the option to edit a .php file and make some columns smaller.

Thanks again,
HTaina

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sunovisio
Sr. Member
 
Avatar
Total Posts:  94
Joined:  2012-04-12
Ho Chi Minh
 

Hi Horatiu Taina,

We are working on one of our client server to fix the issue. The issue cause is pretty simple as it is due to MySql Memory.

We made modification directly in Varien library to fix the issue (which is not the best way we know that already). We are still working on it.

Will keep this post updated as soon as we find the best solution.

 
Magento Community Magento Community
Magento Community
Magento Community
 
aqua26
Jr. Member
 
Total Posts:  3
Joined:  2010-11-16
 
Horatiu Taina - 29 October 2012 04:47 AM

By the way…

I switched ‘Used in product listing’ to “NO” for my attributes… Reindexing works fine now.

But still… there should be the option to edit a .php file and make some columns smaller.

Thanks again,
HTaina

No that does not work for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
satish
Enthusiast
 
Total Posts:  812
Joined:  2008-03-24
34,mantri Sadan,Shivaji Nagar,Nagpur,MS,India 4400
 
aqua26 - 05 January 2013 12:19 AM

Horatiu Taina - 29 October 2012 04:47 AM
By the way…

I switched ‘Used in product listing’ to “NO” for my attributes… Reindexing works fine now.

But still… there should be the option to edit a .php file and make some columns smaller.

Thanks again,
HTaina

No that does not work for me.

‘Used in product listing’ to “NO” : This should be set to no to improve indexing speed as all attributed that are set to yes results in an additional column in flat table.

Apart from that if indexing fails check your error log.

To edit field size you can do directly at DB level(only advanced developers should).

else create a new version for module and in that have an sql statement as per magento standards that alters field length.

Satish

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top