Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Thumbnails not showing for product
 
sabdsouza
Jr. Member
 
Total Posts:  1
Joined:  2012-10-24
 

Hello Everyone,

For clarification I am not a developer/coder, I am simply a System Administrator. The issue that I am facing is just one product thumbnails is not showing, however when the product is clicked the images show.

<img src=\\\"media/catalog/product/cache/1/small_image/135x/9df78eab33525d08d6e5fb8d27136e95/images/catalog/product/placeholder/small_image.jpg\\\" width=\\\"135\\\" height=\\\"135\\\" alt=\\\"FAROS Audi A3 05-08 3 trg + Sportback\\\">

-rwxrwxrwx 1 1663 Oct 24 13:20 small_image.jpg

Through Admin panel > Manage products > Select any product > Images > and upload an image it shows the thumbnail.

I really have tried searching on this forum but whenever there is coding involved I am totally lost. If anyone can let me know what to do exactly I would follow the instructions.

There are 2000+ images that would really take time upload, if all can be updated with a code would be great. I am not able to export the product in csv fomat, it shows blank page, however I managed to add MageWork and export category csv

I have followed below and much more but still no luck
http://turnkeye.com/blog/magento-images-not-showing/

Any help would be appreciated

I just checked the manually uploaded image has the following path

<img media/catalog/product/cache/1/small_image/135x/9df78eab33525d08d6e5fb8d27136e95/9/9/9999691_1.jpg” width="135" height="135" alt="BISAGRA DEL CAP? Alfa Romeo 147 04-09">

whereas all other images have
<img src=/media/catalog/product/cache/1/small_image/135x/9df78eab33525d08d6e5fb8d27136e95/images/catalog/product/placeholder/small_image.jpg” width="135" height="135" alt="ANTINIEBLAS Audi A3 05-08 3 trg + Sportback">

It seems to be something with placeholder for images

 
Magento Community Magento Community
Magento Community
Magento Community
 
videohead
Jr. Member
 
Total Posts:  22
Joined:  2010-10-14
 

From looking at this, you might want to ensure that your image descriptions are safe for SQL insertion. Some of the input fields in Magento will erroneously encode the data that is input in order to make it safe for SQL - add slashes, etc.
You can take a look at the PHP expression mysql_real_escape_string for some guidance.
My advice would be to try inserting some image descriptions that do not have slashes or apostrophes and see if they work correctly.
There are lots of automation routines for Magento. You can go for a straight SQL approach or use the API, which is what I recommend. If you can’t figure out how to do the programming, there are lots of professionals available across the world.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top