Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 6
Troubleshooting and bug reports
 
FOOMAN
Guru
 
Avatar
Total Posts:  669
Joined:  2007-12-13
Auckland, New Zealand
 

Can you please make sure that you don’t have any other extensions installed which could interfere.

http://www.magentocommerce.com/boards/viewthread/32948/

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ben Marks
Guru
 
Avatar
Total Posts:  452
Joined:  2008-10-09
Charleston, SC
 

Sorry I didn’t reply to your PM - it was in fact the Canonical URL extension that was the culprit.

 
Magento Community Magento Community
Magento Community
Magento Community
 
GVal
Jr. Member
 
Total Posts:  15
Joined:  2009-03-05
 

Also failed on step 3 internal server error.

Using a store in sub folder /demo/

installed Yoast_Blank_Seo_Theme

boxes in default , but not in blanks seo path

please advise

thx

 
Magento Community Magento Community
Magento Community
Magento Community
 
GVal
Jr. Member
 
Total Posts:  15
Joined:  2009-03-05
 

I also have Zenprint_ordershp installed

thx

 
Magento Community Magento Community
Magento Community
Magento Community
 
Loic_LC
Sr. Member
 
Avatar
Total Posts:  194
Joined:  2007-12-19
Paris, France
 

Hello.

Everything works fine except that I don’t have any css pictures showing.
It seems that pics’ links are broken.

I run from a folder, not from webroot.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
FOOMAN
Guru
 
Avatar
Total Posts:  669
Joined:  2007-12-13
Auckland, New Zealand
 

@loic - can you look at the source of your site. Then copy and paste the src link for the css into a separate window. You should then see the paths for the images inside the css. Anything apparently wrong?

A few more things to try:
update to the latest Speedster release
verify that in your htacces you have changed the RewriteBase to /yourfolder/
add a <base href="http://www.example.com/directory/" /> to your pages

 
Magento Community Magento Community
Magento Community
Magento Community
 
Loic_LC
Sr. Member
 
Avatar
Total Posts:  194
Joined:  2007-12-19
Paris, France
 

Thank you Fooman.
When I copy and paste the src link, they are wrong.
- The path of images in the css are correct, because they display ok without the extention.
- I have the lastest release,
- the htacces is having the RewriteBase to /yourfolder/

where should i add <base href="http://www.example.com/directory/" /> ?

thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
FOOMAN
Guru
 
Avatar
Total Posts:  669
Joined:  2007-12-13
Auckland, New Zealand
 

<base href ... should go into
/app/design/frontend/YOUR/THEME/template/page/html/head.phtml

Can you post or pm the actual links/paths in the format of my first post.

 
Magento Community Magento Community
Magento Community
Magento Community
 
FOOMAN
Guru
 
Avatar
Total Posts:  669
Joined:  2007-12-13
Auckland, New Zealand
 

<base href ... should go into
/app/design/frontend/YOUR/THEME/template/page/html/head.phtml

Can you post or pm the actual links/paths in the format of my first post.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ylibrach
Sr. Member
 
Total Posts:  78
Joined:  2008-07-06
 

Hi Fooman,

I have set up all the folders correctly, but I’m not getting anything when going to http://MYSITE/lib/minify/m.php… I get a 404 both when I go to the that link and also when i go to http://MYSITE/lib/minify/m.php?f=/skin/frontend/default/default/css/boxes.css.

I’ve verified that the CSS file is existing in that directory. What do you think could be wrong? Here is the content of the right part of the .htaccess file:

############################################
## you can put here your magento root folder
## path relative to web root

RewriteBase /

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## Compress, Combine and Cache Javascript/CSS

RewriteRule ^(index.php/)?minify/([^/]+)(/.*.(js|css))$ lib/minify/m.php?f=$3&d;=$2

Also, obviously my website is installed in the root folder (not /magento or anything like that).

 
Magento Community Magento Community
Magento Community
Magento Community
 
ylibrach
Sr. Member
 
Total Posts:  78
Joined:  2008-07-06
 

Also I should probably note the 404s I’m getting are not the server based 404, but the Magento “Whoops, our bad” pages.

 
Magento Community Magento Community
Magento Community
Magento Community
 
FOOMAN
Guru
 
Avatar
Total Posts:  669
Joined:  2007-12-13
Auckland, New Zealand
 

@ylibrach - it seems that your rewrite rule is not working. Not sure if this is just on the forum but it looks an additional ; got into it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ylibrach
Sr. Member
 
Total Posts:  78
Joined:  2008-07-06
 

Hi Fooman, thanks for the fast reply. Yea the ; was an error in the forum, because it’s not in my .htaccess file.

What do you think the reason is for the rewrites not working? I know they are enabled on the server…

 
Magento Community Magento Community
Magento Community
Magento Community
 
FOOMAN
Guru
 
Avatar
Total Posts:  669
Joined:  2007-12-13
Auckland, New Zealand
 

http://MYSITE/lib/minify/m.php shouldn’t redirect to the Magento woops page. Please verify that the permissions for m.php and the parent folders are correct.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Loic_LC
Sr. Member
 
Avatar
Total Posts:  194
Joined:  2007-12-19
Paris, France
 

Hello again Fooman,

I did your test, all with success. I still don’t have css images showing. (all other css attributes are fine)
when I view the source I get this :

http://127.0.0.1/magento/minify/0/skin/frontend/default/petiteparis/css/reset.css,/skin/frontend/default/petiteparis/css/boxes.css,/skin/frontend/default/petiteparis/css/menu.css,/skin/frontend/default/petiteparis/css/clears.css

Is this normal the first part of the adress of CSS doesn’t appear for boxes.css, menu.css & clear.css ?

I did add a <base href="http://127.0.0.1/magento/" /> to my head.phtml
Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 6