Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problems with using https for secure URLs
 
chabermann
Jr. Member
 
Total Posts:  2
Joined:  2011-03-26
 

Hey,

i am using Magento 1.7.0.2 CE and i have the following problem:

When i use http:// for both secure and unsecure urls everything works fine. If i use https:// again for both, secure and unsecured urls it works fine too.

BUT: If i am using http:// for unsecure and https:// for secure urls i get a problem in step 4 during the checkout process. I an choose a payment method and click to the next step but nothing happens!?

It stills loads again the same site an i have to choose the payment method again?

Any ideas? Perhaps i am just to stupid to do it right or is it something with webserver configuration?

Thanks in advance!

 
Magento Community Magento Community
Magento Community
Magento Community
 
mansontech
Jr. Member
 
Total Posts:  6
Joined:  2012-10-19
 

Hi! The point is, https already means secure URL, so you can’t use it for insecure URL.
Http is insecure, and it won’t become secure uinless you configure it correctly and obtain the SSL. I think, there must be something wrong with the settings.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top