Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Invalid PHP Version on SLES10
 
thehailo
Jr. Member
 
Total Posts:  1
Joined:  2008-01-30
 

Hey all,

I started looking into Magento 0.7.15480 full this morning, unfortunately I got stuck pretty early. I’ve got an i686 Dell box running SUSE Linux Enterprise Server 10 SP1, fully updated. I went ahead and installed everything required which wasn’t already, basically some PHP modules. I also upgraded my PHP install to 5.2.5 by hand per the requirements. I’m still getting the following message when I try to bring up the installation-wizard:

Whoops, it looks like you have an invalid PHP version.
Magento supports PHP 5.2.0 or newer. Find out how to install Magento using PHP-CGI as a work-around.

I’d rather not do the work-around simply because the box should meet all of the requirements so I’d rather fix the core issue. It’s a dedicated box running PHP 5.2.4 as an Apache module, MySQL 5.0.26-12.13, php5-pdo 5.1.2-29.50 (is this the correct module?), and php5_mysqli 5.1.2-29.50.

I’d post the phpinfo.php file as requested but well, it doesn’t load because of the error. The only thing I changed in my .htaccess was telling it that the root was in the /shop subdirectory, but here’s the changed code just in case:

#############################################
#
## you can put here your magento root folder path relative to web root
#
 
#
    RewriteBase /shop/

Any thoughts? I’ve already tried many of the ideas listed on the forum as touched on above. The permissions look fine, the software looks fine, I tried replacing a file (literally file.php if I recall) with a patched version from a previous thread, as well as downgrading PHP from 5.2.5 (after upgrading from 5.1.2) to avoid hassles others have mentioned. Just not sure what’s left to try.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

I’d post the phpinfo.php file as requested but well, it doesn’t load because of the error.

I’m not sure I understand this sentence. Create a file phpinfo.php:

<?php
phpinfo
();
Browse to it and attach the output.
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top