Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PayPal IPN Issue on Magento 1.6.2
 
LewisSellers
Member
 
Total Posts:  33
Joined:  2009-06-02
 

Hi There,

We upgraded our store a while back to Magento 1.6.2.0. Our store has a few modifications on such as the One Step Checkout, but ever since upgrading, our PayPal IPN hasn’t worked correctly so we have to manually check if people have paid for their items or not.

Looking into PayPal, I can see that our Notification URL is as follows:

https://www.ourdomain.co.uk/paypal/standard/ipn/

I do however receive emails from PayPal regularly saying:

"Dear OUR COMPANY,

Please check your server that handles PayPal Instant Payment Notification
(IPN) messages. Messages sent to the following URL(s) are not being
received:

https://www.ourdomain.co.uk/paypal/standard/ipn/


If you do not recognize this URL, you may be using a service provider that
is using IPN on your behalf. Please contact your service provider with the
above information.

Once you or your service provider fix this problem, you or your service
provider can resend the failed messages from the IPN History page. If this
problem continues, PayPal may disable the IPN feature for your account.

Thank you for your prompt attention to this issue.

Yours sincerely,

PayPal
"

I have contacted One Step Checkout as I thought it may be a problem with their mod. They told me that it’s not related to OSC as it tries to reach the URL which gives a 404 error. I’ve had a look around the Magento forums and this seems to be a common issue with the PayPal checkout in 1.6.2.0.

Is there a fix for this? Or could I reinstall the whole PayPal checkout in Magento to try and solve the issue?

Kind regards,
Lewis

 
Magento Community Magento Community
Magento Community
Magento Community
 
kalenjordan
Sr. Member
 
Avatar
Total Posts:  218
Joined:  2011-10-31
Pasadena, CA
 

I found this post which appears to be dealing with the same issue.  It may be a Magento bug.  But it appears that there is a debug mode you can enable to get some more detail around what exactly is failing.  In the case of that post, it was an issue with a missing template file.

Also, CE 1.7.0.0 lists “Fixed: Paypal IPN post back failure” as a bug fix.  May be worth upgrading to see if that fixes it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
LewisSellers
Member
 
Total Posts:  33
Joined:  2009-06-02
 

Hi There,

Thanks for your reply.

Unfortunately, upgrading the whole of Magento isn’t something that I can see working very for us at present. The page you suggested seems to be related to PayPal Web Payments Pro, whereas we are using the PayPal Standard payments system. I assume it’s the same kind of issue so it may be relevant.

Would it work me just taking the PayPal payment module from the v1.7 version of Magento, or is this likely to break things?

I could do with getting this fixed asap.

Many thanks,
Lewis

 
Magento Community Magento Community
Magento Community
Magento Community
 
kalenjordan
Sr. Member
 
Avatar
Total Posts:  218
Joined:  2011-10-31
Pasadena, CA
 

Hey @Lewis, hm sorry about that.  I think I glazed over that, b/c I figured that if it had to do with IPN it would have to be paypal standard.  But at any rate, what I would do is try to flip on some logging so that you can see what exactly is happening when the IPN request hits your server.

 
Magento Community Magento Community
Magento Community
Magento Community
 
LewisSellers
Member
 
Total Posts:  33
Joined:  2009-06-02
 

Hi Guys,

Thanks for all the help so far. I thought I’d update this because I think I’ve got bit further down the line with the problem!

I’ve updated IPN recently and it’s been updating orders as processing, but then suddenly out the blue, I got another one of those errors!

Someone in the office pointed out that It might be down to eBay. We use the M2EPro Extension here - http://m2epro.com/

It basically imports everything from our Glowstick account back into Magento so we process all our orders from there. When people pay, it updates the orders correctly etc, but I think that’s what’s causing the issue.

I received an error this morning so I logged into PayPal and looked at the IPN log. I could see the following:

eBay Order - Retrying
Website Order - Sent
eBay Order - Failed
Website Order - Sent
Website Order - Sent
Website Order - Sent

So, the only ones that have failed / retrying are from eBay…

The orders show as processing in our Magento store when they come from eBay (assuming they’ve paid) but I’m a little confused with this.

Has anyone else come across this problem and can they help?

Kind regards,
Lewis

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top